Home Quicken for Mac Errors and Troubleshooting (Mac)

Calendar pop-up defaults to Dec 31, 2999 (or 1899 or 1900) (Q Mac)

SKawalkoSKawalko Member ✭✭
Running Quicken Mac Deluxe 2020 version 5.15.1 on MacOS 0.14.6

If I try to change the date on any transaction using the calendar pop-up the date in the pop-up defaults to Dec 31, 2999.

Best Answers

«134

Answers

  • Quicken_TykaQuicken_Tyka Moderator mod
    Hello @SKawalko

    Thank you for taking the time to visit the Community to post your issue, although I apologize that you haven't received a response.

    I am currently unable to recreate this in my Quicken.

    Are you seeing this in every single account or a specific account? If a specific account, what type of account is it?

    Does this also occur if you create a new transaction?

    Please let me know!
    -Quicken Tyka
  • SKawalkoSKawalko Member ✭✭
    The problem occurs in all accounts and with both existing and new transactions. I've even created a completely new Quicken file and the problem occurs with any account I create in the new Quicken file.
  • Quicken_TykaQuicken_Tyka Moderator mod
    Hello @SKawalko

    Thank you for the response and for providing additional details.

    If you haven't done so already, I would start by going to File > Save a Back and proceed with uninstalling and reinstalling the application.

    Steps and information on uninstalling/reinstalling are available here.

    Let me know how it goes!
    -Quicken Tyka
  • RickORickO SuperUser ✭✭✭✭✭
    I would also check that your calendar settings in System Preferences > Language & Region are the defaults. Check Region, Calendar (Gregorian), and Advanced > Dates.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • SKawalkoSKawalko Member ✭✭
    I have the MacOS calendar type set to ISO 8601 to get calendar week numbering in Calendar to be consistent with how my employer numbers calendar weeks. If I switch back to Gregorian, the calendar pop-up behaves properly. So, it's a problem with how Quicken parses dates when the calendar type is ISO 8601.
  • RickORickO SuperUser ✭✭✭✭✭
    edited March 17
    Well, there's your answer unfortunately. I can replicate this on my end.

    Now that you have the cause determined, you should use menu Help > Report a Problem to let Quicken know. (You won't get any feedback from this method.) You may also want to contact support direct via phone or chat to make sure they get the message. I have no idea how easy or difficult a fix for this might be.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • Fred M. RhoadesFred M. Rhoades Member ✭✭
    When I click new and then click on the calendar box, rather than showing the current year it shows 1899. If you hand edit the date, the correct year shows up. BUG!
  • Zach LambrinonZach Lambrinon Member ✭✭
    When entering a date using the pop up calerdar, the default date is Jan 1900 and not the current date
  • RickORickO SuperUser ✭✭✭✭✭
    Check that in System Preferences > Language & Region > Calendar is set to Gregorian. Setting it to something else can cause this. 

    To answer your general question, submit bugs by clicking the Help menu then Report a Problem.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • Fred M. RhoadesFred M. Rhoades Member ✭✭
    Thanks; I'll check
  • TomTom Member ✭✭
    Just upgraded (FRIDAY Update Again), and I have noticed the same thing. IF I choose the Calendar to edit a date on the transaction a few days, it comes up with
  • Zach LambrinonZach Lambrinon Member ✭✭
    > @RickO said:
    > Check that in System Preferences > Language & Region > Calendar is set to Gregorian. Setting it to something else can cause this. 

    Thanks. This is already set that way. This issue ust happened with update Version 5.15.2 (Build 515.33015.100)
  • mbond12345mbond12345 Member
    When entering a date using the pop up calendar, the default date is Jan 1900 and not the current date--checked language and region panel...
    Version 5.15.2 (Build 515.33015.100)
  • jasnmoorejasnmoore Member
    December 31, 1899 will be the date displayed by default when you select to display the calendar in the date field of an account register
  • RickORickO SuperUser ✭✭✭✭✭
    I concur. I tested immediately before and after updating from 5.15.1 to 5.15.2. Before the update, the date was today. Immediately after the update, the date was Jan 1900 in my case. I will try to get Quicken's eyes on this asap.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • Agreed. Using macOS 10.12.6 and Quicken Version 5.15.2 (Build 515.33015.100) the default date in the register is set to Jan 1900 not the current date. What a royal pain that is!! How do we get the date to stop going back to Jan 1900? This problem only occurred after I installed the latest Quicken update this morning.
  • bahjr826bahjr826 Member
    Downloaded and installed Mac Version 5.15.2 (Build 515.33015.100) this morning (macOS 10.15.3). Pop up calendar in date field defaults to January 1, 1900. Have restarted, etc. No change. Easy to work around but annoying.
  • jacobsjacobs SuperUser ✭✭✭✭✭
    Please use Help > Report a Problem to report this bug. The more people who do so, the more likely it will get quick notice and attention for a fix.
    QMac 2007 & QMac Subscription • Quicken user since 1993
  • RickORickO SuperUser ✭✭✭✭✭
    edited March 21
    It's been reported to Quicken. I expect it will be fixed in the next update. In the mean time, it's not really a big deal. There are three solutions in the interim:

    1. Click the Today button (one extra click)
    2. Don't click the calendar popup; type the date instead
    3. Don't click the calendar popup; use the keyboard shortcuts:



    Just to clarify, it is only happening in the popup calendar, right? If this is happening to you for the date itself, that's a new twist. But in that case, methods 2 & 3 above will be the workaround until it's fixed.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • RickORickO SuperUser ✭✭✭✭✭
    It's been reported to Quicken.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • jacobsjacobs SuperUser ✭✭✭✭✭
    @RickO I was only suggesting that sometimes multiple problem reports helps an issue get quick attention. They don't need a thousand reports, but reports from several people of the same issue can help it pop out for immediate notice. If anyone knows it has been acknowledged by Quicken Marcus or one of the development team, then it becomes unnecessary to continue to report it. 
    QMac 2007 & QMac Subscription • Quicken user since 1993
  • bahjr826bahjr826 Member
    Thanks for the help, but damned if I can find Help > Report a Problem. It's probably obvious to SuperUsers, not so much to groundlings like me.
  • RickORickO SuperUser ✭✭✭✭✭
    Help > Report a Problem is within the Quicken program. Launch Quicken, then click the Help menu at the top, then Report a Problem.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • jchriscookjchriscook Member ✭✭
    Check attached to find "Report a Problem"
  • bahjr826bahjr826 Member
    Ha! Thanks again. As usual I was in the wrong weed patch.
  • Zach LambrinonZach Lambrinon Member ✭✭
    > @RickO said:
    > It's been reported to Quicken. I expect it will be fixed in the next update. In the mean time, it's not really a big deal. There are three solutions in the interim:
    >
    > 1. Click the Today button (one extra click)
    > 2. Don't click the calendar popup; type the date instead
    > 3. Don't click the calendar popup; use the keyboard shortcuts:
    >
    > (Image)
    >
    >
    > Just to clarify, it is only happening in the popup calendar, right? If this is happening to you for the date itself, that's a new twist. But in that case, methods 2 & 3 above will be the workaround until it's fixed.

    Yup. Just the pop up. Agreed, not a big deal. Just a matter of changing habits until an update is released but at least wanted to mention it.
  • Michael227Michael227 Member ✭✭
    When opening a new transaction the date is correct. However, if you attempt to change the date by clicking on the calendar icon it defaults to "Dec 1899". Happens for me in all accounts.
  • UKRUKR SuperUser ✭✭✭✭✭
    edited March 21
    Multiple discussions under way in the Community on that subject.
    A possible solution is being discussed here:
    [removed self-referencing link]

  • MarieRediessMarieRediess Member
    3 updates ago (currently 5.15.2 Quicken for Mac 2020) the check amount stopped filling in with the amount from the last check -- handy for ongoing payments -- now, not so much. Today's update messed up the calendar. As you probably know, it is difficult to just type in a date - the calendar always pops up - the pop-up calendar was January 1900 rather than this month's calendar. It took over five minutes to scroll 120 years. What a pain. It seems to me that this program is working less and less well with each update. You're breaking stuff instead of fixing them. I am SO sorry I fell for the update today. 3/21/19
Sign In or Register to comment.