Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Transactions in mobile app are all uncategorized

I'm using the mobile app with my iPhone 10, syncing to my quicken data on my Windows 10 PC running Quicken R28.18 build 27.1.28.18. I have no idea what version of the mobile app I am using but it shows 5.21.0 (38.18836.4012) above the Sign Out button and I only recently downloaded the app a couple of weeks ago.

None of the transactions on the mobile app are categorized - the transactions in Quicken are all categorized. I am syncing 3 accounts from one bank.
Is there a setting to skip this info during syncs that I need to change?

Note: every time I sync I get an error:
The category "(category)" was not synced. Illegal Operation {0}
8 of these messages for 8 different categories appear. None of these categories listed in the sync error message are used in any of the three accounts I am syncing on the app.

Thanks,
Ralph

Best Answer

  • Ralph Page
    Ralph Page Member ✭✭
    Accepted Answer
    The problem was solved with Lupe's help. I did two things at once so I don't know which action really did the trick or maybe I needed to do both.
    1. I renamed all the old categories that produced:
    the category "(category)" was not synced. Illegal Operation {0}
    error message when I was syncing. All the categories were sub-categories that started with '+', I got rid of the '+' and made a new main category as well for them.
    2. I deleted the app from my phone and reinstalled it. After re-installation it reported a different number above the 'Sign Out' button which I assume is the app version - 6.0.3 vs 5.21.0. I use iOS 13
    After these two actions, I no longer get any errors reported during sync and all the transactions on the phone are properly categorized.

Answers

  • Quicken Anja
    Quicken Anja Moderator mod
    edited August 2020
    Hello @Ralph Page,

    Thank you for reaching out and telling us about your issue, though I am sorry to hear that you are experiencing this.

    The first thing I suggest you try is to reset your cloud data by following the steps below.
    1. Sign out of your Mobile App
    2. Open Quicken on your computer and go to Edit
    3. Preferences
    4. Mobile & Web
    5. Make sure sync shows it's ON and click on Reset your cloud data (see below)
    6. Wait for the sync to complete, then sign back in on the Mobile App and see if the issue still persists.
    Let us know how it goes and/or if you have any additional questions!
    -Quicken Anja
  • Ralph Page
    Ralph Page Member ✭✭
    Thanks for the help.
    In the past week I have reset my cloud data several times in attempts to resolve the category not synced error.
    I just did it again per instructions after signing out of mobile app.
    I then found it couldn't sign in to mobile app. After hitting the sign in button I get a blank screen with the little progress spinning icon for minutes.
    I quit the app and re-opened it with the same result.
    I turned the phone on and off and I was able then to sign back in to the app.
    All transactions still show 'uncategorized'.
    Any further suggestions? Thanks for the help
    -Ralph
  • Quicken Anja
    Quicken Anja Moderator mod
    Thank you for the update.

    Well, I must admit that is puzzling.

    In that case, you can try manually resetting your cloud data by deleting your cloud account from a test file and then resyncing your main data file which will create a new cloud account.

    The following steps below do also include signing out and back in of the Quicken Mobile app as well. I understand you just ran into some trouble trying to get back in there, so if you don't want to sign out again, feel free to try these steps without doing so. However, should that still not resolve the issue, then I do recommend trying it with signing out and back in.

    To do this, first, save a backup (just in case). Sign out of the Quicken Mobile app. Then, create a new data file (click here to view instructions, scroll down to Creating a new file). Once the new file opens, follow the steps below to remove the cloud account from your main data file.
    1. Go to Edit
    2. Preferences
    3. Quicken ID & Cloud Accounts
    4. Cloud accounts associated with this Quicken ID (#)
    5. Select the cloud account used for you main data file and click Delete
    6. Type Yes and click Delete
    After that, switch back to your main data file (click here to view instructions, scroll down to How to alternate between multiple files). Once the main file opens, follow the instructions found in the support article to resync your data. If successful, sign back in to your Quicken Mobile app(s). You can then also delete the new file you previously created as well as it's cloud account.

    I hope this helps and let me know if anything needs to be clarified.
    -Quicken Anja
  • Ralph Page
    Ralph Page Member ✭✭
    Hi Anja,
    I did something very similar to this working on the related problem (no help).
    I tried it again though.
    1. Created new data file (TestFile2).
    2. went to: Edit/Preferences/QuickenID.../Cloud acounts associated...
    3. I saw the new test account and the real account
    4. I deleted the real account (Not the new test account).
    5.In quicken I switched back to my real account.
    6. I started following instructions in support article-"How to set up and sync..." for Quicken for Windows.
    7.Support article indicates that under the the Mobile&Web menu I should see 'Get Started'. I don't see that, it looks just as it always has before.
    8. I Then went back to Mobile&Web/Add or Remove Accounts to sync. I found the three accounts in the list still checked even thought i deleted this account in step 4 above.
    9. I hit cancel and went back to edit/preferences/ Mobile & Web and it now reports 'We could not retrieve your cloud account info' - because I deleted this account in step 4?

    I stopped at this point and I am showing you what I did since I am not sure what to do next or what I may have done incorrectly.

    Thanks,

    -Ralph
  • Quicken Anja
    Quicken Anja Moderator mod
    edited August 2020
    Thank you for trying the steps.

    Since you encountered some errors in following these steps (doesn't sound like you followed the steps incorrectly), I suggest following the steps below to sign out and back in on the desktop program to resync the file.
    1. Go to Edit
    2. Preferences
    3. Quicken ID & Cloud accounts
    4. Sign in as a different user (or it might say Sign in using a different Quicken ID)
    5. Follow the prompts to Sign Out
    6. Sign back in using your Quicken ID (email) and password 
    After signing back in, you should get a prompt asking you if you want to use Mobile & Web and that choice should already be checked. Once you are back in your data file go back to Mobile & Web in Preferences and please let me know if you still receive the same error message or if it shows sync is on or something else.
    -Quicken Anja
  • Ralph Page
    Ralph Page Member ✭✭
    Thanks.
    I followed steps 1-6, signing back in with my Quicken ID
    I saw a 'success!' page and clicked done.
    This brought me back to my usual Quicken page, no query asking if I want to use Mobile and Web.
    Edit/Preferences/Mobile&Web revealed that the accounts I previously had set up were still set up.
    I sync'ed via the desktop program. The usual errors for 8 categories (not used in the accounts I sync) were seen.
    All transactions on the iPhone app are still are uncategorized.

    Another thing I notice which may have no impact on t his issue:
    I sync 3 bank accounts and a Merrill Lynch brokerage account. As far as my iPhone is concerned, the Merrill Lynch brokerage account doesn't exist, it's never been listed under Accounts, only the three bank accounts.

    -Ralph
  • Quicken_Tyka
    Quicken_Tyka Moderator mod
    Hello @Ralph Page

    Thank you for the response and for the additional details. I wanted to confirm the correct data file is being viewed on the mobile app. 

    This could explain this behavior and may not be readily noticeable. 

    In the desktop version, please navigate to Edit > Preferences > Quicken ID & Cloud accounts, look for the "Dataset Name."

    Please make a note of this name, as you'll need to compare it in just a moment.

    Please sign in to the mobile app and select the, here you can select which data file to view, from the Mobile App. Please confirm this matches what is on the desktop version.

    Please let us know!

    -Quicken Tyka

    ~~~***~~~
  • Ralph Page
    Ralph Page Member ✭✭
    Missed your response, I was chatting with Lupe in support.
    Yes, the dataset name in the desktop matches the file name I see when I use the mobile App. In addition, I changed the data file at least once during my chat with Lupe.
    We spent a couple of hours without success on the chat and Lupe will call me today (I hope) to continue troubleshooting.
    Thanks for the help.
    If I resolve this I will report it here in case it's helpful to folks reading this exchange.
    -Ralph
  • Ralph Page
    Ralph Page Member ✭✭
    Accepted Answer
    The problem was solved with Lupe's help. I did two things at once so I don't know which action really did the trick or maybe I needed to do both.
    1. I renamed all the old categories that produced:
    the category "(category)" was not synced. Illegal Operation {0}
    error message when I was syncing. All the categories were sub-categories that started with '+', I got rid of the '+' and made a new main category as well for them.
    2. I deleted the app from my phone and reinstalled it. After re-installation it reported a different number above the 'Sign Out' button which I assume is the app version - 6.0.3 vs 5.21.0. I use iOS 13
    After these two actions, I no longer get any errors reported during sync and all the transactions on the phone are properly categorized.
This discussion has been closed.