Roth 401k Support?

Hello.  When I set up my Roth 401k account in Quicken at the beginning of this year I noticed there wasn't anything asking me what type of 401k it was.  When I added my deposits from my paycheck I just set it as an "Other After-Tax Deduction".

Today, I was looking at my Projected Tax for 2020 and saw my wages were way under what they should be.  Looking in the Tax Planner I see it is treating my transfers to my Roth 401k as if it were a regular 401k and subtracting that amount from my wages.

Is there really no support for Roth 401k accounts in Quicken?  Or did I do something wrong?

Quicken Premier - Windows 10 VM on a Mac

Best Answers

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited October 2020 Accepted Answer
    I suggest you prevent Quicken from maintaining the Tax Impact of 401(k) Accounts entries for the paychecks transfers into the Roth 401(k) account.  This may be achieved by first selecting an entry in the Transfers in pull-down menu and then clearing the entry: open the account, press Ctrl + Shift + E, and select Tax Schedule

Answers

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    As far as I can see, there isn't any support for it.  It might be possible to shoehorn it in if you can connect a Roth IRA to the download and then change things up in the paycheck, but it certainly wouldn't be easy (and maybe not even possible) to get everything to line up correctly.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited October 2020 Accepted Answer
    I suggest you prevent Quicken from maintaining the Tax Impact of 401(k) Accounts entries for the paychecks transfers into the Roth 401(k) account.  This may be achieved by first selecting an entry in the Transfers in pull-down menu and then clearing the entry: open the account, press Ctrl + Shift + E, and select Tax Schedule

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Are your Roth 401(k) holdings in an account by themselves, or is it one account that has both Roth and non-Roth contributions and holdings?

    And are you downloading the 401(k) transactions or entering them manually? If it is a separate account for the Roth contributions and you are entering them manually, you might be able to tell Quicken the Roth account is a Roth IRA and record the Roth contributions there.

    In my former employer's 401(k) and I think most others, it is all one account, and Quicken assumes that all 401(k) holdings are traditional, i.e. non-Roth.

    If that is your situation, the best approach may be the one recommended by @harris15213 here
    https://community.quicken.com/discussion/7878902/how-to-get-from-fidelity-401k-to-multiple-accounts-by-the-source#latest
    QWin Premier subscription
  • richard13
    richard13 Member ✭✭✭
    @Sherlock: Thanks for the suggestion.  I tried this but nothing changed.  Incidentally, "Transfers in" was empty to begin with.  Adding and removing an entry didn't change my situation.  I think what's going on here is that the 401k account type associates any transfers with the _401Contrib category on the back end and is causing my problem.

    @Jim_Harman: Thanks for the suggestion.  I guess I could try setting up my Roth 401k as a Roth IRA account but I wonder what other problems I may encounter by doing so.

    Quite frankly, I'm super disappointed that Quicken doesn't just support Roth 401k accounts by default.  It's not some exotic investment vehicle.  This seems like an odd omission.
    Quicken Premier - Windows 10 VM on a Mac
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    The difficulty in many cases (perhaps not yours) is that Roth and pre-tax contributions to a 401(k) are held in one account and Quicken does not support mixed accounts like that.
    QWin Premier subscription
  • richard13
    richard13 Member ✭✭✭
    Yea, I should have mentioned this in my previous reply.  The current Roth 401k is with MassMutual which does not have downloads so I am manually managing it in Quicken.  So, no worries there.  I do also have Fidelity accounts which do have downloads (including a former employer's traditional 401k).  But I never made post-tax contributions into that account so I do not have the problem the other person has on the other thread.
    Quicken Premier - Windows 10 VM on a Mac
  • richard13
    richard13 Member ✭✭✭
    Sherlock said:
    richard13 said:
    @Sherlock: Thanks for the suggestion.  I tried this but nothing changed.  Incidentally, "Transfers in" was empty to begin with.  Adding and removing an entry didn't change my situation.  I think what's going on here is that the 401k account type associates any transfers with the _401Contrib category on the back end and is causing my problem.

    I suspect you did not select Yes when prompted to delete the transactions in the Tax Impact account and/or you did not select No when prompted to include the transactions in the Tax Impact account.   The _401Contrib category is used on these transactions which are eliminated if you answer the prompts appropriately.  I suggest you try again.
    Thank you Sherlock!  You were right.  I made the wrong responses to the dialog boxes here.  So, that fixes my Roth 401k.  But now I notice that my deposits to my HSA account are not being subtracted from my earnings for tax estimation even though it is a pre-tax item.  Could I use this method in reverse to "fix" that?  Or is that a completely other thing?
    Quicken Premier - Windows 10 VM on a Mac
  • richard13
    richard13 Member ✭✭✭
    Sherlock said:
    richard13 said:
    Sherlock said:
    richard13 said:
    @Sherlock: Thanks for the suggestion.  I tried this but nothing changed.  Incidentally, "Transfers in" was empty to begin with.  Adding and removing an entry didn't change my situation.  I think what's going on here is that the 401k account type associates any transfers with the _401Contrib category on the back end and is causing my problem.

    I suspect you did not select Yes when prompted to delete the transactions in the Tax Impact account and/or you did not select No when prompted to include the transactions in the Tax Impact account.   The _401Contrib category is used on these transactions which are eliminated if you answer the prompts appropriately.  I suggest you try again.
    Thank you Sherlock!  You were right.  I made the wrong responses to the dialog boxes here.  So, that fixes my Roth 401k.  But now I notice that my deposits to my HSA account are not being subtracted from my earnings for tax estimation even though it is a pre-tax item.  Could I use this method in reverse to "fix" that?  Or is that a completely other thing?
    The HSA account should be a completely other thing.  To have HSA contributions from a paycheck reduce earnings, the entry should have an appropriate W-2:Salary or wages tax-line item associated with it.  The tax-line item associated with an entry in a paycheck transaction in a register may be accessed by opening the paycheck transaction as a split: press Ctrl + Shift + S, select the entry and Edit > Tax line item assignments  To apply the tax-line item to all transfers to the HSA account, we may set the Transfers in pull-down menu to the appropriate W-2:Salary or wages tax-line item.
    Great!  Thanks again Sherlock!  I think I'm all set for now.
    Quicken Premier - Windows 10 VM on a Mac
  • brandongblack
    brandongblack Member ✭✭✭
    @richard13 & @Sherlock
    I just stumbled upon this thread from last year because i had  similar issue with my new Roth 401k also through massmutual (all manual transactions)

    While Sherlock's workaround does work, the issue i notice is that each time a new 401k transfer is entered from a scheduled paycheck in quicken, quicken is automatically assuming that because its from your paycheck that its a traditional contribution and therefore was deducting it from my taxable income. The reason I know this is because if you manually try to add a transaction to your 401k it asks you "is this from an employee?" if you say "no" then its ok but if you say "yes" then it causes the issue. So my guess is any 401k contribution from a paycheck quicken automatically assumes "yes" to that question

    So this means each paycheck youd have to perform the tax schedule workaround from Sherlock. 

    However I found another workaround thats slightly less annoying:
    1) Change the contribution on your paycheck to a non-transfer category such as "roth contribution". might have to create a new category if its not there
    2) add a new recurring scheduled income bill which aligns with your paycheck schedule and specify the amount & set the category as the account name (transfer from itself)
    3) each time you get paid, youll need to enter both the paycheck bill reminder AND the 401k deposit reminder.

    After testing the above scenario it works and doesn't impact the taxable income for roth contribution.

    To be honest, this is pretty bad that quicken doesn't have a solution for this in 2021. They need to get with the program and build "Roth vs Traditional" options when contributing via paycheck. Would save a lot of headache..its not like Roth 401ks are that new either...

    Thank You,
     Brandon
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    @richard13 & @Sherlock
    I just stumbled upon this thread from last year because i had  similar issue with my new Roth 401k also through massmutual (all manual transactions)

    While Sherlock's workaround does work, the issue i notice is that each time a new 401k transfer is entered from a scheduled paycheck in quicken, quicken is automatically assuming that because its from your paycheck that its a traditional contribution and therefore was deducting it from my taxable income. The reason I know this is because if you manually try to add a transaction to your 401k it asks you "is this from an employee?" if you say "no" then its ok but if you say "yes" then it causes the issue. So my guess is any 401k contribution from a paycheck quicken automatically assumes "yes" to that question

    So this means each paycheck youd have to perform the tax schedule workaround from Sherlock. 

    However I found another workaround thats slightly less annoying:
    1) Change the contribution on your paycheck to a non-transfer category such as "roth contribution". might have to create a new category if its not there
    2) add a new recurring scheduled income bill which aligns with your paycheck schedule and specify the amount & set the category as the account name (transfer from itself)
    3) each time you get paid, youll need to enter both the paycheck bill reminder AND the 401k deposit reminder.

    After testing the above scenario it works and doesn't impact the taxable income for roth contribution.

    To be honest, this is pretty bad that quicken doesn't have a solution for this in 2021. They need to get with the program and build "Roth vs Traditional" options when contributing via paycheck. Would save a lot of headache..its not like Roth 401ks are that new either...

    Thank You,
     Brandon

    @brandongblack

    The reason you are prompted with Is this an Employee Contribution to your 401(k)? is because you chose to use the Cash Transferred into Account wizard or to enter the Xin action transaction in the 401(k) account register.  There are many other ways we may enter a transfer of funds between accounts and avoid the prompt.  For example, initiate the transfer from the source account.
Sign In or Register to comment.