Home Quicken for Windows Errors and Troubleshooting (Windows)
Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Sporadic "parameter deleted" error causes cloud sync to fail

This problem keeps recurring, and I have a theory where the issue lies.

The problem manifests as follows: I've synced with my financial institutions, checked off matches, entered new transactions, and modified ones I'd already entered. When I'm done, I close Quicken, saying "yes" to cloud sync. I get a "parameter has been deleted" error, and the cloud sync fails.

If I reset my cloud data, the problem goes away, but eventually--after 2-3 more sessions--it recurs. Resetting constantly is an annoyance, since the mobile apps take a long time to download the resetted data.

I've run Verify and Superverify on the (large) data file, and that's uncovered no errors.

Thing is, the problem doesn't happen every time. However, I'm beginning to think that I see a pattern: the problem seems to arise if I've changed anything about a transaction already in my register (or maybe a transaction with a split, or maybe one that's from a reminder), but I think it hasn't arisen when I've left existing transactions and entered reminders as they are. That is, I think for some reason a change in an existing transaction is for some reason triggering the "parameter deleted" error, even though a Verify finds no problems and the the error doesn't recur if I reset the cloud data.

Also, many times after I've done the reset I get a weird "syncing your data to Quicken's new cloud service" message across the top of my One Step Update progress screen. It starts 0% complete, then says 52% complete, then says 100% complete. And it says this is a one-time upload. But I have no idea what "Quicken's new cloud service" is, and it's certainly not a one-time upload since it periodically happens again.

Best Answer

  • Quicken AnjaQuicken Anja Moderator mod
    Accepted Answer
    Thank you for the update, though I apologize that the issue continues to persist and for not having received a follow-up response yet.

    Since, unfortunately, the previous steps failed, next, if you haven't already, I suggest you try manually resetting your cloud data by creating a new (test) data file and deleting your cloud account from that test file. After that, you would attempt to resync your main data file which should then create a new cloud account (this does not affect your data saved within that data file).

    Before doing so, first, verify that the Dataset name and the File name match each other identically by navigating to Edit > Preferences > Quicken ID & Cloud Accounts (see below). 



    If they do not match, please click Edit dataset name and change the Dataset name to match the File name exactly the same (do not copy the file extension: ".QDF"). 

    Then, click OK in the preferences window and proceed to Save a backup (just in case). From there, sign out of the Quicken Mobile and/or Web apps if you are currently signed in, and on your desktop program, create a new data file (click here to view instructions, scroll down to Instructions and open the blue dropdown section titled: "Creating a new file"). Once the new file opens, follow the steps below to remove your main data file's cloud account.
    1. Go to Edit
    2. Preferences
    3. Quicken ID & Cloud Accounts
    4. Click Cloud accounts associated with this Quicken ID (#) (this is not a button, it is written in blue underneath the "Edit dataset name" button)
    5. Select the Cloud Account Name used for your main data file and click Delete
    6. Type Yes and click Delete

    After that, switch back to your main data file (click here to view instructions, scroll down to Instructions and open the blue dropdown section titled: "How to alternate between multiple files"). 

    Once your main file opens, resync your data by navigating to the Mobile & Web tab and click on the blue Sync Now button. If successful, you can then sign back in on the Mobile and/or Web apps if you wish, and can also delete the new (test) file you previously created as well as its cloud account.

    If that fails or you prefer to have assistance, then at that point I do recommend contacting Quicken Support via chat or phone in case you may need more extensive troubleshooting done and/or possibly have an escalation filed with our Tier 2 team. Our support agents also have the ability to screen share with you if you're comfortable doing so.

    I hope this helps and let us know if you have any additional questions!
    -Quicken Anja

Answers

  • jgacksonjgackson Member
    Here's a screenshot of the error:
  • Quicken_TykaQuicken_Tyka Moderator mod
    Hello @jgackson

    Thank you for taking the time to visit the Community to report your issue, although I apologize that you have not received a response.

    First, please navigate to Help > About Quicken and provide the release that you are currently running.

    As to the "New Quicken Cloud Service" There have been some changes to the sync process and transaction download process. To learn more, I would take a moment to review the previous discussions available here and here.

    As for the Parameter error, I would try to sign out and sign back in.
    1. Go to Edit > Preferences > Quicken ID & Cloud accounts
    2. Click sign in as a different user
    3. Type "yes" to sign out
    4. After you sign out, sign back in with the same Quicken ID

    Please let me know if this error message persists after completing this step.

    -Quicken Tyka
    ~~~***~~~
  • jgacksonjgackson Member
    R29.22; sorry I forgot to include that originally.

    Since the error is sporadic, there's no way to tell yet whether your suggestion, which I just tried, worked. It did yield a different and slower "one time" sync to the "improved cloud service", whatever that is. If my theory is correct, the true test will come the next time I modify an existing transaction (for example, to change its split, or the total amount).
  • jgacksonjgackson Member
    Your suggestion did not fix the problem, as it's now recurred. My new hypothesis, thinking about what I'd done just before the "parameter has been deleted" error recurred, is that changing something in a split "bills and income" reminder causes the next sync to fail.
  • Quicken AnjaQuicken Anja Moderator mod
    Hello @jgackson,

    Thank you for reaching out to the Community to tell us about your issue, though I apologize that it continues to persist and for not having received a follow-up response yet.

    If you haven't already, I recommend that you create a copy of your data file by following the instructions provided below in an attempt to rebuild all of the internal lists and database tables.
    1. Go to File
    2. File Operations
    3. Copy...
    4. Leave the presets as is and click OK
    5. Wait for the copy procedure to complete
    6. Select New copy and click OK  


    Once the newly copied file opens, see if the issue persists or resolves. If it does persist, please, try validating and super validating again as well as resetting the cloud data.

    Let us know how it goes!
    -Quicken Anja
  • jgacksonjgackson Member
    Moving to a new copy of the file didn't fix the problem. It still recurs.

    It's looking very much as though the problem occurs whenever there's a change to a scheduled/reminder transaction. For example, I just told Quicken to ignore a scheduled transaction (a credit card payment where there was a zero balance, hence no need to pay) and then I got the "parameter deleted" error. This was on a freshly copied file. It also happens, I think, when I modify the amount on a reminder transaction I've already entered (eg, I was expecting the NYTimes charge to be $96, as usual, but it came through as $90, so I modified the already-entered reminder transaction so that it would match the downloaded one)

    As usual, file validation finds nothing awry.
  • Quicken AnjaQuicken Anja Moderator mod
    Accepted Answer
    Thank you for the update, though I apologize that the issue continues to persist and for not having received a follow-up response yet.

    Since, unfortunately, the previous steps failed, next, if you haven't already, I suggest you try manually resetting your cloud data by creating a new (test) data file and deleting your cloud account from that test file. After that, you would attempt to resync your main data file which should then create a new cloud account (this does not affect your data saved within that data file).

    Before doing so, first, verify that the Dataset name and the File name match each other identically by navigating to Edit > Preferences > Quicken ID & Cloud Accounts (see below). 



    If they do not match, please click Edit dataset name and change the Dataset name to match the File name exactly the same (do not copy the file extension: ".QDF"). 

    Then, click OK in the preferences window and proceed to Save a backup (just in case). From there, sign out of the Quicken Mobile and/or Web apps if you are currently signed in, and on your desktop program, create a new data file (click here to view instructions, scroll down to Instructions and open the blue dropdown section titled: "Creating a new file"). Once the new file opens, follow the steps below to remove your main data file's cloud account.
    1. Go to Edit
    2. Preferences
    3. Quicken ID & Cloud Accounts
    4. Click Cloud accounts associated with this Quicken ID (#) (this is not a button, it is written in blue underneath the "Edit dataset name" button)
    5. Select the Cloud Account Name used for your main data file and click Delete
    6. Type Yes and click Delete

    After that, switch back to your main data file (click here to view instructions, scroll down to Instructions and open the blue dropdown section titled: "How to alternate between multiple files"). 

    Once your main file opens, resync your data by navigating to the Mobile & Web tab and click on the blue Sync Now button. If successful, you can then sign back in on the Mobile and/or Web apps if you wish, and can also delete the new (test) file you previously created as well as its cloud account.

    If that fails or you prefer to have assistance, then at that point I do recommend contacting Quicken Support via chat or phone in case you may need more extensive troubleshooting done and/or possibly have an escalation filed with our Tier 2 team. Our support agents also have the ability to screen share with you if you're comfortable doing so.

    I hope this helps and let us know if you have any additional questions!
    -Quicken Anja
Sign In or Register to comment.