Search Text in Split-Transaction Memo Field

It appears that Quicken Find (or Search) feature does not find transactions where the desired search text is beyond the 30th character in a split-transaction Memo field. For example, if in a split-transaction, the text string "The quick brown fox jumps over the lazy dog" is entered into the memo field, a search on the Memo field containing the text "the lazy dog", will result in "no matching transactions were found." This anomaly is not exhibited if the same text string is entered into the register memo field (i.e. non-split transaction).

Comments

  • Quicken Anja
    Quicken Anja Moderator mod
    Hello @essjay,

    Thank you for reaching out to the Community to tell us about your issue, though I apologize that you are experiencing this.

    Could you please provide which version of Quicken you have currently running?
    • Help > About Quicken

    I just tested the issue you described in my own Quicken and was not able to replicate it. The register-search did successfully find both the non-split as well as the split transaction where the memo field had entries using more than 30 characters (I used the same text for both split and non-split transactions).

    That said, if you don't mind, I'd like to start off by having you create a new (test) file to see if you experience the same issue in a new file as well. In doing so, we will be able to determine whether or not this is caused by an issue within your current data file.

    Follow the steps below to create a test file:
    1. Choose File menu > New Quicken File.Advanced Data File Troubleshooting to Correct Problems With Quicken for Windows
    2. Select New Quicken File.Advanced Data File Troubleshooting to Correct Problems With Quicken for Windows
    3. Click OK.
    4. In the File name field, enter the name of the new file, then click Save. Use a name like "Test File" to easily be able to tell it apart from your main file. Advanced Data File Troubleshooting to Correct Problems With Quicken for WindowsDon't use any of these characters: * ? < > | " : \ / (asterisk, question mark, left and right-angle bracket, pipe, straight quotation marks, colon, BACKSLASH, FORWARD SLASH). Also, don't add the .qdf extension; Quicken does that for you.
    5. Sign in with your Quicken ID (if prompted). If you are prompted to create a Quicken ID, click Sign In under the Create Account prompt. 
    6. Select to not use Mobile (if prompted).
    7. Click Add Account and add a manual account for testing (click +Offline Account to add a manual account)

    After adding a manual account, add at least 3 (dummy) transactions - e.g.: 2 non-split transactions and one split transaction. Enter the same text (longer than 30 characters) to the memo field for 1 of the non-split transactions, and to the memo field for 1 split entry of the split transaction. Leave the memo field for the 2nd non-split transaction blank. Then, proceed to search the last word of the text you entered in the memo fields to see if you are experiencing the same problem in this test file. If the search works successfully; only the 2 transactions (1 split and 1 non-split) with memo field entries should show, and the transaction with no memo field should not show.

     From there, you can then switch back to your original file. 

    Follow the steps below to switch files:

    1. Click the File menu.
    2. Look near the bottom of the options list.
    3. Select the data file you want to open. 


    Quicken will list the most recently opened data files, with a checkmark next to the file you are currently viewing.

    Let us know how it goes!

    -Quicken Anja
  • essjay
    essjay Member ✭✭
    Hello, and thank you for the response. The version of Quicken I was using when I noted this issue was Deluxe Build 27.1.30.21. I have since updated to the latest patch 27.1.31.20 and the problem is still apparent.

    I created a new data file in accordance with your instructions. I created a single off-line "cash" account and entered 3 transactions: 2 non-split and 1 split. I entered the text string "the quick brown fox jumps ove_r the lazy dog" in the memo field of the first non-split transaction, and the same text in the memo field of the split transaction. (Please note, the underscore in the text "ove_r" represents the 30th character.)

    Using the search bar in the upper right corner of the title bar, if I search for any portion of the string occurring before and including the underscore, I get two transactions returned (1 split and 1 non-split). If I search for any text after the underscore, only the non-split transaction is returned. To illustrate the issue further, I searched for "ove_r" and only the one, non-split transaction returned a match. It appears that the memo field in a split-transaction is being truncated at 30 characters for searching purposes.

    I also tried using Edit->Find->Any Field->Contains "string" with the same results.

    Since you were unable to reproduce this issue, perhaps it is some configuration and/or preference difference between our data files. Please advise if there is something else to try.
  • Quicken Anja
    Quicken Anja Moderator mod
    edited March 6
    Thank you for the update and additional information, though I apologize for the delay in my response.

    Did you also try the Search field within the account register located below the account name and above the date column (see below)?



    Please, check back and let me know! Thank you.
    -Quicken Anja
  • essjay
    essjay Member ✭✭
    The filter search in the account register works properly. Thank you.
  • Quicken Anja
    Quicken Anja Moderator mod
    edited April 19
    @essjay thanks for the update! I'm glad to hear the search field above the register worked for you. :)

    I did also test the other two search fields you mentioned and found that those did indeed not work with finding split transactions using more than 30 characters in the memo field. Therefore, I went ahead and submitted a bug report for those two search fields to our Development and Product teams for further investigation and resolution.

    Unfortunately, we won't have an ETA on this. However, once a solution is created it will be made available as part of a future update release.

    Thank you for your patience and for bringing awareness to this issue!
    (QWIN-18981/CTP-1937)
    -Quicken Anja
This discussion has been closed.