Excluding tagged transactions in reports doesn't work with multiple tags

KDL
KDL Member ✭✭
edited May 22 in Reports (Windows)
I'm running Quicken Premier R31.2 on Windows 10. I have itemized category reports showing spending for a particular time period. I am trying to exclude certain transactions using tags. In the customize report box, I have unchecked a tag. If a transaction has a single tag that matches, it works. But if the transaction has multiple tags, it is not excluded. This seems like a bug to me. What I want is that any transaction using that tag is excluded regardless of other tags present. The tags should work independently. Anyone else seeing this problem?

Best Answer

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited March 2021 Answer ✓
    This is not a bug IMO.

    Essentially Quicken is doing a logical OR between the tags, which is what users usually want. If a transaction has multiple tags and one or more of them is selected to be included in the report, the transaction is included. 

    What we are looking for here is the AND NOT operation.

    Try this:

    On the Tags tab of the report customization, select all the tags you want to include in the report and then in the Tag Contains box at the right, type the tag you want to exclude with a tilde (~) in front. 

    Tilde is the shifted version of the key to the left of the "1" key on most keyboards.
    QWin Premier subscription

Answers

  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    I don't believe this is "new behavior."  As far as I know Quicken has always worked this way.  Tags have always struck me as sort of an afterthought on the part of Quicken programmers as the program simply doesn't control them very well.
  • Quicken_Tyka
    Quicken_Tyka Alumni ✭✭✭✭
    Hello @KDL

    Thank you for taking the time to visit the Community to report this issue. I was able to successfully recreate this.



    I have gone ahead and reported this as a bug. I will be back with an update as soon as I have more information.

    Thank you!

    -Quicken Tyka
    ~~~***~~~
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited March 2021 Answer ✓
    This is not a bug IMO.

    Essentially Quicken is doing a logical OR between the tags, which is what users usually want. If a transaction has multiple tags and one or more of them is selected to be included in the report, the transaction is included. 

    What we are looking for here is the AND NOT operation.

    Try this:

    On the Tags tab of the report customization, select all the tags you want to include in the report and then in the Tag Contains box at the right, type the tag you want to exclude with a tilde (~) in front. 

    Tilde is the shifted version of the key to the left of the "1" key on most keyboards.
    QWin Premier subscription
  • KDL
    KDL Member ✭✭
    @Jim_Harman good solution. That works. Didn't know we could do that.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Glad that worked for you, @KDL.

    Until you asked, I didn't know we could do that either!.
    QWin Premier subscription
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Glad that worked for you, @KDL.

    Until you asked, I didn't know we could do that either!.
    Note I believe this works only for one tag.  You can't put in multiple tags in this way.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Quicken_Tyka
    Quicken_Tyka Alumni ✭✭✭✭
    Hello all,

    Thank you for your patience I have a small update. This was deemed as not a bug and working as designed. However, this issue is being reviewed as a potential feature request.  I will be back with an update as soon as more information becomes available

    Thank you,
    -Quicken Tyka
    ~~~***~~~
  • JohnL.Miller
    JohnL.Miller Member ✭✭✭
    The tag selection process seems to have changed a little, but not for the better. To state things as simply as I can, I run a report selecting tag "A". As expected, the report includes transactions tagged with only "A", as well as transactions tagged with "A" and "B" and those tagged with "A" and "C". If I exclude either "B" or "C" (using the "~B" or "~C" syntax), *all* multiply-tagged transactions are excluded, not just the ones explicitly excluded (e.g., "~B" excludes transactions tagged with either "B" or "C"). I can't imagine a scenario where this behavior would be considered intentional.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    @JohnL.Miller
    Did you put the "~B" in the dropdown box under Tag contains on the Tags tab of the report customization?

    Did this work correctly at one time? What version of Quicken are you running that has this problem?


    QWin Premier subscription
  • KDL
    KDL Member ✭✭
    I haven't needed this function recently, but I anticpate needing it again soon. I'll have to check it out.
  • JohnL.Miller
    JohnL.Miller Member ✭✭✭
    I'm running H&B v R39.21build 27.1.39.1. This is the first time I've tried to use this capability, so I can't speak to previous behavior. And yes, I specified "~B" in the "Tag contains" box. I don't think there's any other place that would accept that option specification.
  • JohnL.Miller
    JohnL.Miller Member ✭✭✭
    Oops - correction - I'm running Deluxe. I downgraded from H&B several years ago.
This discussion has been closed.