T. Rowe Price and Unidentified Security

The Merg
The Merg Member ✭✭✭✭
edited October 4 in Investing (Windows)
I have two accounts at T. Rowe Price for mutual funds. One account has 10 securities in it and the other has 4 securities in it. The one with 4 securities is downloading just fine. I am having a huge issue with the other account.

Two of the funds appear to be downloading correctly. One fund downloads with the wrong fund name (and symbol) and the other 7 all download as "Unidentified Security". I have contacted T. Rowe Price and they tell me that the information I am downloading is correct and the issue is on Quicken's end. I contacted Quicken and they told me the issue is on T. Rowe Price's side.

Quicken's resolution was to try a workaround that talks about removing the ticker symbol, but that workaround did not work. Their other workaround was to rename the "Unidentified Security" and then "Memorize investment transaction".

Does anyone have any thoughts on this? Is there anything that I can look for in the log files that can point me to where this issue is coming from?

Thanks,
Merg

Comments

  • Quicken Francisco
    Quicken Francisco Alumni ✭✭✭✭
    Hello @The Merg

    Thank you for reaching out to the Community regarding your issue, although I am sorry to hear that you are experiencing issues with your mutual funds. I was taking a look at previous posts to see if I was able to find someone with a similar issue and did see an article about unidentified securities. I'd recommend taking a look to see if it might help with the issue you're having.

    https://community.quicken.com/discussion/7795439/unidentified-security-problem-solution

    Once you get the chance let us know if this helps you out if not we'll see what we can attempt next.

    Thanks,
    Quicken Francisco