Have to give permission to staff & everyone to restore backup file over data file

TechnoJock Member ✭✭
Can anyone explain why I had to grant the above permissions to my existing data file in order to restore from a backup? I have a Mac Mini & MacBook and when I travel I backup the file - restore it on the MacBook which went fine. However, upon returning and trying to restore to my Mini - I was told I did not have sufficient privileges to overwrite the existing data file. I'm the owner and only user - doesn't make any sense. Thanks in advance.


  • Quicken Anja
    Quicken Anja Moderator mod
    Hello @TechnoJock,

    Thank you for reaching out to the Community and describing your issue, though I apologize that you are experiencing this.

    In order to better assist you further, if you don't mind, could you please provide a screenshot of the error message you described receiving? If needed, please refer to this Community FAQ for instructions on how to attach a screenshot. Alternatively, you can also drag and drop screenshots to your response if you are not given the option to add attachments.

    Thank you!

    -Quicken Anja
    Make sure to sign up for the email digest to see a round up of your top posts.

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    How, exactly, were you trying to replace your current data file? Insufficient permission is a macOS issue, not something managed by Quicken. I’m trying to understand exactly how you were doing this.
    Quicken Mac Subscription • Quicken user since 1993
  • TechnoJock
    TechnoJock Member ✭✭
    When I received the error - I did a File/Restore From Backup...

    I then selected the backup file, then selected where to restore - which was to to overwrite the existing Quicken data directory.

    I then received the message indicating inability to restore the file due to permissions. I believe it also recommended doing a "Get Info" on the existing directory to see what permissions were present.

    I did such things and it showed that I had Read & Write permissions, "Staff" and "Everyone" had read-only permissions. I'm assuming this is Mac OS's implementation of Linux/Unix owner/group/world.

    I gave staff & everyone read & write permission and it worked.

    Just doesn't make sense to me. As far as posting an image - I guess I can do that should I run into the problem the next time I perform this process. I really don't want to start mucking with these files just for shiggles.

This discussion has been closed.