Update Accounts can't find/update any accounts past most recently added one

For at least a month if not more, account updating investment accounts fails with an error "OL-362-A : Your financial institution has downloaded data for an account that does not exist in your Quicken data file".

I've deactivated the online services for all the accounts and reactivated each successfully.
Once I do an update post activation all but one of them start failing again. Finally I deactivated all of them and enabled just one, that one worked perfectly fine for 10 or so updates, but once I activated another online service for an investment account, the one that was working stops working with the above error, and the new one works fine. Then when I activate another one, THAT previously working one stops working, while the new one now works. It seems only the most recently activated account updates fine, while all the ones added before that fail with the above error.

If I deselect the working financial account when doing the update, the others still fail.

This does not seem to affect banking or credit card accounts, just investment accounts.
Tagged:

Comments

  • Quicken Anja
    Quicken Anja Moderator mod
    Hello @D. Grazier,

    Thank you for reaching out to the Community and telling us about your issue, though I apologize that you are experiencing this.

    If you haven't already,could you please try deactivating the accounts experiencing this issue and then reactivating through Add Account (not through Set Up Now), please?

    Please, follow the steps found in this support article to deactivate. Once deactivated, to reactivate through Add Account, navigate to Tools > Add Account..., search for your Financial Institution name and follow the prompts to connect. Once your accounts have been found, be sure to link them to the existing accounts you have already set up in Quicken. Repeat this process for each financial institution.

    Let us know how it goes!
    -Quicken Anja
  • I did the Tools -> Add Account... for each of the accounts. It's still the case that after adding an account, that account will update and continue to update no matter how many times I press Update Accounts, while all the previously added investment accounts will fail with the error above.
  • papabarr
    papabarr Member
    I have the same EXACT problem, except that it only started on 11/12/2021.
  • Hello all, 

    Thank you for taking the time to update the discussion with your progress, questions, and concerns. I do have a follow-up question if that's ok.

    Are all of the affected accounts within the same financial institution and under the same user name and password?  

    Looking forward to hearing back from you guys on this.



    Quicken Alyssa 

  • They are all different institutions with different user names and passwords. All are brokerage accounts.

    I have restarted quicken numerous times. I have run the validate and repair to validate and rebuild investing lots since this started as well, but that didn't change behavior, despite finding and fixing a fair amount of issues.
  • Hello @D. Grazier & @papabarr,

    Thank you for that update. 

    Can I have you open a new quicken file and try adding the accounts there? This way we can rule out this being an issue in your file.

    To do this;
    1. Go to File.
    2. Select New Quicken File from the menu options.
    3. Again choose New Quicken File and click Ok.
    4. Name the file "test" and click Save.
    5. Click Next and then click Add Accounts.
    6. Now start adding in the accounts that you are having issues with, in the original file. 

    Do you see the same issue happening here?



    Quicken Alyssa
  • Account update works without issue when I create a new quicken file and add accounts. No matter how many times I update, there's no errors and all accounts are updated.
  • Hello again @D. Grazier

    Thank you for that update.

    So let's move you into a new file. This will require you to reconnect ALL accounts in your file.

    Doing this can also result in having to delete some duplicates that may download when you reconnect your accounts. I like to suggest reconciling the accounts before you take these steps so that you can easily tell which transactions are newly downloaded. This makes it easier to spot any duplicates. 

    To do this;
    1. Go to File.
    2. Select Copy or Backup File from the menu options.
    3. Choose the second option for Create a Copy or Template and click Next.
    4. Click Save Copy.
    5. When asked which file you would like to open, choose the New Copy and click Ok.
    6. Reconnect accounts and link them back to the existing accounts.

    Has this resolved your issue?



    Quicken Alyssa

  • I'll let you know as soon as I get a chance to do this.
  • So I just completed reconnecting two brokerage accounts to a new copy of the file and the issue is the same as the original file. Only the most recently added account will update.
  • Within the copy I made, I also tried deleting all the accounts under 'investing' and adding them back. The results were the same; problem still exists. There is something fundamentally wrong with data file that doesn't exist in a new file.
  • So I'm taking a stab that the root of the issue is changing the Account Name and account update keeps trying to use the old account name, despite the record for in the ledger having the new account name.

    It's a guess based upon intuition from years doing IT support sparked by recent issues in auto download after a rename (I'm reenabling auto download one at a time to get downloads and then disabling to avoid the original issue):

    I renamed the account and on the next download of transactions, all the transactions for Shares Bought had "From" in the "use cash for this transaction" as the new account name, yet it wasn't deducted from the cash balance. When I changed it to "from this account's cash balance", it properly deducted it from the cash balance. So this is telling me there's a disconnect between the account names that account update can see and the actual account names in the ledger.
  • I don't know if my comment had anything to do with it, but after the last update to quicken, this problem looks to have been fixed. Updated 3 accounts at once without issue.
  • Well ugh.... I spoke too soon. I had updated 3 accounts that were setup for online update prior to the update that worked all at once. Once I added another account to do online update, the others stopped working just like in the original problem.
This discussion has been closed.