Cost Basis After Mutual Fund Conversion

zkaps
zkaps Member ✭✭
edited May 5 in Investing (Windows)
I converted a Mutual Fund from Class A to Class I shares by using the Mutual Fund Conversion in "Enter Transactions". I moved the "Added" shares introduced by the conversion to a new account using "Move Transactions" (CTL + SHIFT +N). The source account now correctly has zero shares, the new account has the correct number of shares BUT when I check the cost basis in the new account using the Portfolio and Cost Basis report or looking at the tax lots using CTL + U, the cost basis is an astronomical number not even close to what it's supposed to be.

Does anyone know what the problem might be ?
Thanks,
zkaps

Comments

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    The Added transactions should be establishing the appropriate cost basis of the lots.  I suggest you review the transactions to confirm they're correct.  You should also confirm the cost basis by opening the account register and selecting Holdings.  If these check out okay, the issue you're experiencing may be due to the way the Portfolio and Cost Basis report and Portfolio view are customized with regard to the new security and new account.

    Regarding the report, do not trust the includes all/any option on tabs of the Customize window of a report.  The feature was added relatively recently and does not reliably determine whether all the items are selected. 

    To prevent Quicken from incorrectly defaulting to the all/any option in a Saved report, I suggest unchecking an unhidden item for each tab.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    There is a bug in the Mutual Fund Conversion transaction that causes the cost basis to be wrong if the old fund is set to "Use average cost." If there are N tax lots of the fund being converted, the cost basis ends up being N times what it should be.

    I suggest you delete the Removed and Added transactions resulting from the conversion, set Use average cost to No and try it again. 
    QWin Premier subscription
  • zkaps
    zkaps Member ✭✭
    Jim, you're good. I just did a quick multiplication of what I think the cost basis should be by the no. of tax lots I see in the new account and the result is within 0.05% of the incorrect basis in Quicken. Having spent many years in IT, testing conversions prior to actually doing them is in my blood so I came across this problem in a copy of my "production" file so no harm. Hopefully your workaround works.
    Thanks,
    zkaps
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    If you have not sold a portion of this holding in the past, there should be no ill effects from turning off Use average cost before doing the share class conversion. 

    If you have made one or more partial sales, it would be a good idea to compare Quicken's cost basis for the converted tax lots to your broker's records to make sure they are the same.

    I generally avoid the Average cost option so that I can minimize capital gains taxes by choosing the lots to sell.
    QWin Premier subscription
  • zkaps
    zkaps Member ✭✭
    As far as comparing the cost basis with the broker's records, is there somewhere in Quicken where I can see the cost basis for Covered and Non-Covered shares separately ? Since Non-Covered shares must be depleted first, this distinction is important and this is how brokers maintain records.
    Thanks,
    zkaps
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    And if you would like Quicken to fix this longstanding bug, please do all three of the following:

    1. Add your comment and vote to this Idea post
    https://community.quicken.com/discussion/7861196/fix-mutual-fund-conversion-so-cost-basis-is-correct-if-holding-is-set-to-use-average-cost

    2. Report the problem via the Help > Report a problem link and 

    3. Contact Quicken Support by phone or chat and explain the problem to them. Get a ticket number once they agree it is a problem.
    QWin Premier subscription
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    zkaps said:
    As far as comparing the cost basis with the broker's records, is there somewhere in Quicken where I can see the cost basis for Covered and Non-Covered shares separately ? Since Non-Covered shares must be depleted first, this distinction is important and this is how brokers maintain records.
    You can see the cost basis for the individual lots by going to an Investing > Portfolio view that includes the account and security in question. Customize the view to include the Quote/Price, Shares, and Cost basis columns. Next to Group by select Accounts.

    Click on the little plus sign next to the security and it will display all the currently held lots in that account. It does not separate out the covered and uncovered lots but you can see when each lot was purchased.

    You can print or export the view by hitting Ctrl-P or going to File > Print portfolio. The print layout is very antique; it seems reminiscent of the DOS days.
    QWin Premier subscription
  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    "As far as comparing the cost basis with the broker's records, is there somewhere in Quicken where I can see the cost basis for Covered and Non-Covered shares separately ?"
    No, there's no Covered vs. Non-Covered distinction in Quicken. 
    "Since Non-Covered shares must be depleted first, this distinction is important and this is how brokers maintain records."
    That's not literally true.  Typically the default order used by brokers for security sales is First In First Out (FIFO) and if you happened to have a security purchased through a particular broker that bridged the date when "Covered" securities became a thing, the use of FIFO would mean that Non-Covered lots were sold first, but that's a result strictly looking at the dates, not actually making a distinction between Covered and Non-Covered.
    Actually, having an earmark on transactions that made the distinction between Covered and Non-Covered might not be a bad idea.  That way you'd know which group of lots to use if you wanted to cheat on yuor taxes! :D:wink:


This discussion has been closed.