"Unable to contact the Quicken server." Has anyone else seen this recently?

Dana Netherton
Dana Netherton Member ✭✭
My Quicken Deluxe for Windows is version R43.32 Build 27.1.43.32.

This afternoon (25 Oct 2022) I was connected to the Internet via a VPN. When I tried to start Quicken, it gave me an error message before closing. The error message said ... (see "Question," above). Check your connection, it said. I've been working online without problems for several hours now.

Nonetheless I disconnected the VPN and tried again. This time, Quicken did start up without that error message. However, when I tried to "Check for Updates" (via "Help" menu), once again the software complained that it was unable to contact the Quicken server.

Just In Case, I closed all my other windows (leaving only the windows with my browser and Quicken). Ran a routine report, which ran smoothly. Then checked again for updates.

Again -- "unable to contact the Quicken server."

My connection to my WiFi and LAN networks are solid.

Is there anything else I should try?

Answers

  • UKR
    UKR SuperUser ✭✭✭✭✭
    Are you sure that the VPN was completely out of the picture?
    After deactivating the VPN, have you tried rebooting Windows to start "clean", without the VPN active?
  • Rebooting Windows after deactivating the VPN?? Of course not. Would the Quicken server do that to anybody who had a *previously* active VPN during that session on the computer?? Why would someone do that?

    Good Gawd ...

    ... OK, I'll try that. I'll get back to you, probably tomorrow.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    I was asking these particular questions, because I remembered reading some other disucssion where a customer reported similar problems. It was reported that turning off the VPN did not completely remove all network configuration changes made by activating the VPN. Only a reboot put everything back to "normal".
  • fws
    fws Member
    I tried to open Quicken this morning, as I have been doing for about 30 years, but nothing happens. When I called the 650-250-1900 number, just got "We are closed." Any ideas???
  • UKR
    UKR SuperUser ✭✭✭✭✭
    fws said:
    I tried to open Quicken this morning, as I have been doing for about 30 years, but nothing happens. When I called the 650-250-1900 number, just got "We are closed." Any ideas???
    Sorry, Quicken Support is only available during posted hours of operation
    As to the problem ... have you tried again since posting yur message?
    • If the problem persists, try checking your firewall, Antivirus or Windows logs for Internet-related error messages.
    • Quicken needs to be able to establish outbound Internet connections for the program to work, e.g., in McAfee Firewall, one user states "By editing the Quicken Firewall entry Selecting Incoming and Outgoing, and changing it from "Default" to "Open to all devices" it now works without having to turn off the entire firewall!"
      If necessary, contact the Antivirus / Firewall vendor's Support Center.
    • In older Windows systems go to Windows Control Panel and select Internet Options (or in Internet Explorer, click on Tools / Internet options.)
      Click the Advanced tab.
      Scroll down the list to "Use TLS x.x" and click to put a checkmark on all available TLS choices.
      Turn off "Use SSL 3.0"
      Click Apply. Reboot.
    • If all else fails: Try rebooting your network router. When done reboot your PC
  • kevingy
    kevingy Member
    I've been getting the same error for weeks. It started randomly and has never gone away.
    -Firewall and antivirus are confirmed to allow traffic in both directions.
    -This is on Windows 11, not an "older Windows system"
    -I have rebooted the PC and router several times over the last several weeks. I don't have an internet problem. My job requires stable internet. Everything there is 100% functional.
  • > @UKR said:
    > I was asking these particular questions, because I remembered reading some other disucssion where a customer reported similar problems. It was reported that turning off the VPN did not completely remove all network configuration changes made by activating the VPN. Only a reboot put everything back to "normal".

    Thanks, that does make sense.

    After several busy days, I did find a time yesterday when I could shut everything down (including VPN), reboot, and (with Internet connected but VPN still disconnected) try Quicken again. (I had also installed the most recent Windows updates, FWIW.)

    As before, Quicken did start up. As before, when I invited it to check for (Quicken) updates, it gave me an error message that said, "Unable to contact the Quicken server." In other words, no effect.

    tws's remarks don't look related to this. kevingy's remarks look spot-on.
  • kevingy
    kevingy Member
    Also, for me, it doesn't matter if Quicken is checking for updates at application startup or if I go to Help > Check for Updates. I get the same "unable to contact the Quicken server" message.

    I kinda seems like Quicken has a pretty serious bug, if it's continually unable to update itself. I suspect that Quicken will want it's annual membership fee regardless.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Some more things you should check:

    Did you install Windows 10 or 11 Security Updates for October?
    If so, you need to install an additional Windows Update to fix an issue with these updates.
    See https://community.quicken.com/discussion/comment/20307756#Comment_20307756 for more details

    Check your Firewall Rules. To operate properly, Quicken needs three firewall rules as shown below, from my Norton Antivirus:

  • kevingy
    kevingy Member
    No luck. I installed the update. It had no effect. In my firewall, qwsubprocess.exe was not configured. I added it, as shown, it had no effect.

    Still can't update Quicken.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    After adding the firewall rule, did you reboot Windows? Adding a rule may not have taken effect immediately  without rebooting or, at least, restarting Quicken.
  • > @UKR said:
    > Some more things you should check:Did you install
    > Windows 10 or 11 Security Updates for October?
    > If so, you need to
    > install an additional Windows Update to fix an issue with these updates.
    > See https://community.quicken.com/discussion/comment/20307756#Comment_20307756
    > for more details

    This appears to pertain to this comment: "As suggested by several users, my problem turned out to be caused by the October security update from Microsoft. Installing KB5020435, the updated version of the security patch, fixed the problem."

    (checked ... I installed that update on 20 Oct 2022.)

    > @UKR said:
    > Check your Firewall Rules. To operate properly, Quicken needs three firewall rules as shown below, from my Norton Antivirus:


    > @UKR said:
    > After adding the firewall rule, did you reboot Windows? Adding a rule may not have taken effect immediately  without rebooting or, at least, restarting Quicken.

    Following your 2 Nov advisory, I added those three firewall rules. After your 3 Nov query, I rebooted my computer.

    I'll let the screenshots tell the story.

    Upon starting Quicken:
  • Having selected "Show details:"
  • Quicken closed, returning me to my Windows screen/wall. I clicked on Quicken again. This time, it opened without protest. When I chose "Help/Check for Updates," I got this:
  • As you can see, this is no change from the situation I reported on 25 October.

    One additional question. What *is* the current version of Quicken? I cannot find that info on the web site. This is the version currently installed on my computer:
  • UKR
    UKR SuperUser ✭✭✭✭✭
    As you can see, this is no change from the situation I reported on 25 October.

    One additional question. What *is* the current version of Quicken? I cannot find that info on the web site. This is the version currently installed on my computer:
    The current version is R 44.28 and can be downloaded as Mondo Patch file from

    https://www.quicken.com/support/update-and-mondo-patch-20182019-release-quicken-windows-subscription-product

    However, I don't think that this will resolve your unable to contact the Quicken server issue?
    Are you using a VPN?
    Are you located outside the US and Canada?

  • > @UKR said:
    > @Dana Netherton ,
    >
    > The current version is R 44.28 and can be downloaded as Mondo Patch file from
    >
    > https://www.quicken.com/support/update-and-mondo-patch-20182019-release-quicken-windows-subscription-product
    >
    >
    >
    > However, I don't think that this will resolve your unable to contact the Quicken server issue?Are you using a VPN?
    > Are you located outside the US and Canada?

    Thanks. I'll update manually. "won't resolve ..." -- acknowledged.
    No, I wasn't using a VPN when I did all that.
    No, I'm not outside the US and Canada.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Thanks. I'll update manually. "won't resolve ..." -- acknowledged.
    No, I wasn't using a VPN when I did all that.
    No, I'm not outside the US and Canada.
    Thanks for your response.
    I have no idea why you still get this error.

    If you haven't done so already, I'd say it's time to call Quicken Support on the phone and request help.  Let them do a screen share session with you to review the situation on your computer, to determine the nature of the problem and to figure out how to fix it. Maybe they can find something in an installation log file that points to the culprit.

    Quicken Support:

  • > @UKR said:
    > @Dana Netherton ,
    >
    > The current version is R 44.28 and can be downloaded as Mondo Patch file from
    >
    > https://www.quicken.com/support/update-and-mondo-patch-20182019-release-quicken-windows-subscription-product

    Interesting! when I began the update process, I got this notification (see attached screenshot).

    It seems that the patch's software concluded that I was not running Quicken R 43.32, but Quicken R 1.0. It showed me the "What's New/What's Fixed" info on every subsequent update, beginning with R 2.0! And, I suppose, re-installed all the updates from R2.0 through R 43.32. No harm done, probably.

    Oh, and you were right -- the update didn't resolve this "unable to contact the Quicken server" problem some of us have reported. No matter, at least I now have the current version of the software itself.

    Is there a place where I can check (manually) for additional updates -- and then download them (manually)? It seems clear that your link was specific to this 44.28 update.

    Thanks!
  • UKR
    UKR SuperUser ✭✭✭✭✭
    The link I gave you always, albeit with a slight delay, has the latest available Mondo Patch file released for general consumption. When new releases are made available, sometimes several times a month, this webpage is updated to point to the latest file name and, lower down near the bottom, will have updated Release Notes.

    To make sure that Quicken is allowed to update and save its configuration files please check if Windows Defender Controlled Folder Access feature Ransomware protection is enabled.
    If so, configure it to add Quicken as an "allowed app" without turning off Ransomware protection. Perform the last step in https://community.quicken.com/discussion/7857675/faq-windows-defender-controlled-folder-access

    And a few more items to check:
    • Have you recently enabled a VPN?
      If so, this might be the problem. Try turning the VPN off and see if that helps.
    • Is there a corporate or otherwise external firewall getting in the way? Contact the IT people maintaining the firewall and ask for permission.
    • Does your Antivirus software allow Quicken to connect to the Internet?
      Quicken needs to be able to establish outbound Internet connections for the program to work, e.g., in McAfee Firewall,
      one user states "By editing the Quicken Firewall entry Selecting Incoming and Outgoing, and changing it from "Default" to "Open to all devices" it now works without having to turn off the entire firewall!"
      If necessary, contact the Antivirus / Firewall vendor's Support Center.
    • In older Windows systems go to Windows Control Panel and select Internet Options (or in Internet Explorer, click on Tools / Internet options.)
      Click the Advanced tab.
      Scroll down the list to "Use TLS x.x" and click to put a checkmark on all available TLS choices.
      Turn off "Use SSL 3.0"
      Click Apply. Reboot.
    • If all else fails: Try rebooting your network router. When done reboot your PC
  • kevingy
    kevingy Member
    DO NOT follow the instructions to Use TLS 1.0 or TLS 1.1 by "put a checkmark on all available TLS choices". First, this doesn't fix the problem. I tried it just to see. I still couldn't update. Second, TLS 1.0 and 1.1 are vulnerable to downgrade attacks since they rely on SHA-1 hash for the integrity of exchanged messages. This is a technical way of saying these protocols are unsecure.
  • kevingy
    kevingy Member
    I've contacted Quicken Support about this issue three times. Despite the fact that I'm not the only person experiencing this issue, they insist that the problem is my laptop. Their advice is to call Microsoft support and tell them that "Quicken won't update." What do you think that Microsoft is going to say to that?

    Quicken Support is completely useless! Good luck - because that's what it's going to take to fix this. Quicken isn't going to do anything.
  • ASquare
    ASquare Member ✭✭
    edited November 2022
    I was facing a similar issue (could not connect to the Quicken server). I tried clearing my browser cache and support asked me to restart my router. They also asked me to turn off my VPN but it was already disconnected. None of the above worked. They then asked me to restart my laptop and shut down my router for 5 minutes. Rather than doing that, I tried something else: 1- Prevented my VPN software from starting at Windows start, and 2 - Rebooting Windows. After that, I was able to enter my Quicken credentials and it let me through. Quicken was still telling me that it was not able to open my Quicken file, so I had to open it via File Open and it worked. It just finished a One Step update successfully. I believe there must have been something wrong after the most recent Quicken update and something in the Quicken cache might have gotten corrupted.
This discussion has been closed.