BUG - Unable to clear out a security, nano-shares remain. With workaround solution

Tom39 Member ✭✭✭
edited August 2023 in Investing (Windows)

Unable to clear out a security, nano-shares remain. I suspect it's due to a failure with math during stop splits. Reported via quicken problem reporting.

I have an asset I sold years ago. But when I go to Investing >> Dashboard >> Brokerage (or all accounts), small quantities of the asset remain. With -0.000,009 shares (0.9 micro shares or 900 nano shares). I was unable to zero out the account.

I did try going to the last sale I had of 230 shares.
— I had a purchase of 2760 shares
— A 12:1 reverse stock split
— 2760 ÷ 12 = perfect 230 shares, but 0.083,333 division probably done base 2)
— A sale of 230 shares

Here's the split transaction itself. It doesn't show any math being done, just an "old shares / new shares" box..

At that last sale on 11/1/2021, I tried selecting "sell all shares in this account". When I select "Enter/Done", I get a pop up that says "Number of shares selected is more than the available. Maximum available shares on this security is 229."

I tried setting the sale to 229 shares and adjusting the per-share price. Saved. Then when I edit the sale again and select "sell all shares" it auto-adjusts back to 230, then tells me I can only sell 229.

So I can sell 230 shares. But if I try to sell all shares, I'm guessing there's a "divide by 12 " rounding error (binary division vs base 10 division) and the remaining fractional amount has created the error. Search on the quicken board has shown I'm not the only one with this issue.



I found an option once, that gave me a pop up box where you could zero out an security per a certain day, but now I can't find it. I'd appreciate any help.

I found a "Bad but works" fix for the issue. I manually adjusted the shares and changed the original purchase price. This destroys history, but did eliminate the division step that appears to have been occurring in the background. The renaming nano.shares were gone. I prefer not to do that—I prefer for Quicken to work correctly.

A more elegant fix would be for Quicken to utilize base 10 math in all instances, because I have similar instances in occurring in other closed transactions. I'm undoing my fix here (restoring an older data file) because I prefer the issue be fixed rather than me slapping bandaids.


  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭

    I see the same issue. I go to Edit > Preferences > Reports only and set the number of decimal places to 8.

    If I start with 2760 shares and enter a split specifying 230 new shares and 2760 old shares, the Investing > Portfolio Value report shaws 229.999 991 shares. Specifying 1 new and 12 old gives the same result.

    The Holdings view shows 230 shares after the split

    After the split, Quicken will not let me sell all shares or sell 230 shares.

    If I sell 229.999 999 shares, the Holdings view shows that I have .000 001 shares left but the Portfolio Value report shows no shares left..

    Quicken definitely has a rounding issue with division and it is handled differently in different places.

    If I enter a Removed transaction for the .000 001 share that shows in the Holdings view after the sale, the security is gone in both the Holding view and the Portfolio Value report.

    QWin Premier subscription
  • Tom39
    Tom39 Member ✭✭✭
    edited July 2023

    Also worth noting: The Investing » Portfolio tab. shows all my accounts and assets. Aurora as an asset (or the number of shares) never showed up in the asset list in this location, which is why I didn't notice it for so long. Problems seemed to be masked in some areas and not others.

    Your solution is more elegant. I added "0.000009" shares and it cleaned it up.

    I have another post where the shares are correct, but the amount is off by 2 cents. I'll probably try the same as well.

    I've said it before with quicken: The #1 thing to do is get your security solid. #2 is get the money right. I'm hoping #1 is solid because I've had a few posts in the past about #2.

    For another example of of a problem that shows up on some screens/reports, and does not appear in others, see this post:

  • Quicken Kristina
    Quicken Kristina Moderator mod
    edited July 2023

    Hello All,

    Thank you for taking the time to visit the Community to report this issue, though we apologize that you are experiencing this.

    We have forwarded this issue to the proper channels to have this further investigated. In the meantime, if you have not done so already, we request that you please navigate to Help > Report a problem and submit a problem report with log files attached and (if you are willing) a sanitized copy of your data file in order to contribute to the investigation.

    While you will not receive a response through this submission, these reports will help our teams in further investigating the issue. The more problem reports we receive, the better.

    We apologize for any inconvenience!

    Thank you.    


    Quicken Kristina

    Make sure to sign up for the email digest to see a round up of your top posts.

  • Tom39
    Tom39 Member ✭✭✭

    I did report it , that's in my first paragraph (3rd sentence). "Reported via quicken problem reporting." I included detail and a sanitized copy of my data file.

    It appears it's also easily repeatable per Jim Harman who quickly popped it in and made it happen.

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭

    I have also reported along with a sanitized test file.

    QWin Premier subscription
  • Tom39
    Tom39 Member ✭✭✭
    edited July 2023

    I decided to add the shares in just to clear out the annoyance.

    And it worked in the Investing » Dashboard view.

    The Security Detail View matches the register with the remaining shares held. Which makes sense, as it shows the individual transactions from the register.

    But what if I add the the 0.000009 shares on 10/31 to make it happen before the sale, and hope to have zero left in the register?

    • On the sale date, when "sell all shares" was NOT checked,
    -- The register still said I owned 0.000009 shares
    -- The security detail view said I owned 0.000009 shares
    -- The summary at (blue menu bar) Investing >> Dashboard did not show ACB (gone/0 shares)

    • On the sale date, when "sell all shares" WAS checked,
    -- The register said sold 230.000009 shares
    -- The register said I owned zero shares
    -- The security detail view said I owned zero shares
    -- The summary at (blue menu bar) Investing >> Dashboard showed I owned a -0.000009 shares

    I thought I was happy with the shares safely hidden in the register history. Then user KSM reminded me to check my portfolio view which I use more and there they are. Dang it. I use portfolio view more than Investing » Dashboard view, so I have pull the shares back out to move the error to the view I use the least.

    You can either go to 0 (zero) shares
    -- In the register, security detail view, and portfolio view, or
    -- In the Investing >> Dashboard view.
    You cannot have zero shares in both after performing a reverse split with an infinity repeating decimal. The different screens utilize the same number of decimal points, but appear to apply the math differently.

    The mathematically perfect solution is to perform stock splits by manually adjusting shares and price in each historical transaction, instead of using the "stock split" function. It destroys the split history, and If you have a lot of transactions this could take a little time, but it eliminates the Quicken division bug.

This discussion has been closed.