R52.19 - Banking Transaction Report not filtering on Memo [edited]

24

Answers

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭

    The problem is still present in R52.20 and there is no newer release.

    QWin Premier subscription
  • Really need this fixed. I was unable to get the patch to work to regress to a previous version.

  • Joseph Witkin
    Joseph Witkin Member ✭✭✭✭

    Quicken, you need to chime in here. Why is this not listed in the Alerts and Known Issues category? It is clearly an issue!

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭

    I encourage everyone who is experiencing this problem to report it to Quicken using Help > Report a Problem. You will not get any response, but they use the reports to help diagnose the issue and to gauge how many users are affected.

    I recommend you also contact Support via phone.  Be sure the support agent understands the problem and gives you a ticket number for future reference.

    This problem is easy to replicate, but be sure to explain that it affects any report based on the Banking Transaction report that uses "Memo Contains" to filter the transactions based on the contents of the Memo field.

    QWin Premier subscription
  • anyone know a good phone # for calling Quicken support?

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭

    To contact Support, use the number under Help > Contact Support during business hours. There is a different number for the Priority access to Support that comes with Premier and up.

    QWin Premier subscription
  • dlt_lpd
    dlt_lpd Member
    Answer ✓

    Was having the issue with Memo filter not working. I created a new transaction report, added my memo search string. Initially, it did not work, but when I sorted the memo field after the report displayed, it worked.

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited September 2023 Answer ✓

    Excellent observation and a good workaround, @dlt_lpd !

    To restate it in slightly more technical terms, the "Memo contains" filter is applied only if the report is sorted in Memo order.

    If you click on the Memo header to sort the report in Memo order then customize it to specify the "Memo contains" information and any other filters, the report is displayed correctly. If you click on a different header to re-sort, the "Memo contains" filter is ignored. If you click on the Memo header again, the "Memo contains" filter is applied and the report is again displayed correctly.

    Note that this same issue and workaround applies to all reports that are derived from the Banking Transaction report, including banking account Register reports.

    QWin Premier subscription
  • kwkmjk
    kwkmjk Member ✭✭

    Thank you so much for discovering & reporting this work around @dlt_lpd ! And for your follow-up Jim_Harman. A very big help. Still really hope we can get Quicken to fix the issue so these reports work the way they used to do.

    Has anyone heard anything directly from Quicken support by a phone contact ?

  • littlebuffalo
    littlebuffalo Member
    edited September 2023

    The match filter criteria is no longer working in reports. Match characters include = (equal sign) and .. (two periods) and ? (question Mark and ~ (tilde). The user is supposed be able to apply these match filters in the payee or memo or category fields. However, after entering the match characters the report is no longer filter based on the match criteria entered. I have attached a PDF from the user manual showing what I am referring

    to.

    [Merged Post]

  • I am on Quicken Deluxe. Ever since the upgrade to R52.20 Build 27.1.52.20 the report filters that I have setup using text in the "Memo Contains" field have completely stopped working. I am unable to find a solution in the community. Please add me to this issue. Don't you have any automated testing going on before you release and upgrade?

  • Quicken Kristina
    Quicken Kristina Moderator mod
    edited September 2023

    Hello @littlebuffalo,

    Thank you for reaching out to the Community and telling us about this issue.  I'm sorry to hear you're running into this problem. When did this issue first start? Which version of Quicken were you using when it started? What is happening after you enter those characters? Is the report finding nothing that matches, or just displaying as though no filters were applied, or is something else happening?

    Thank you.

    [Merged Post]

    Quicken Kristina

    Make sure to sign up for the email digest to see a round up of your top posts.

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭

    @Bruce Lippold

    If you go back a few comments in this discussion, you will see that there is a workaround for this issue.

    The "Memo contains" filter is applied only if the report is sorted in Memo order.

    If you click on the Memo header to sort the report in Memo order then customize it to specify the "Memo contains" information and any other filters, the report is displayed correctly. If you click on a different header to re-sort, the "Memo contains" filter is ignored. If you click on the Memo header again, the "Memo contains" filter is applied and the report is again displayed correctly.

    Note that this same issue and workaround applies to all reports that are derived from the Banking Transaction report, including banking account Register reports.


    QWin Premier subscription
  • littlebuffalo
    littlebuffalo Member
    edited September 2023

    Kristina,

    I believe the issue started after the last update. (There was another post in the community that also said they were having problems.) I am on Quicken for Windows, Version R52.20, Build 27.1.52.20. The report displays as though no filters were applied.

    [Merged Post]

  • S. Weston
    S. Weston Member ✭✭✭
    edited September 2023

    Same problem and version

    [Merged Post]

  • Quicken Kristina
    Quicken Kristina Moderator mod
    edited September 2023

    Thank you for your reply,

    Is this happening only on certain reports? If so, which ones?

    Thank you.

    [Merged Post]

    Quicken Kristina

    Make sure to sign up for the email digest to see a round up of your top posts.

  • littlebuffalo
    littlebuffalo Member
    edited September 2023

    I have created several of my own reports or customized report templates. The issue seems to be a problem anytime I use the match filter. For example, one of the things I do is put three x's (xxx) in the memo field if I need to go back and search for that transaction to edit it. In my report search I type the match criteria ..xxx.. in the memo line. It is now bringing up the report as if there is no filter. Another example: there are several people in my family and I put a name of one of them in the memo. In the past I would put ..mike.. in the report search and bring up only those transactions with "mike" in the memo. That no longer works. By the way, is there a way we can communicate over the telephone to discuss this back and forth?

    [Merged Post]

  • littlebuffalo
    littlebuffalo Member
    edited September 2023

    Quicken Kristina,

    Upon further research this may only be happening to my saved customized reports. It still do not make sense as everything was working fine until the latest update.

    I'm also curious if you are allowed to contact me directly?

    [Merged Post]

  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    edited September 2023

    I have tested with R52.20: I have no problem using Match criteria to filter report transactions - the Match criteria work every time. 

    My tests were done using reports created from the Quicken Reports menu (I only used one "Match character" per test: I tested using "=", "~" and "..").


    If any of the complainants are experiencing the problem with "saved" reports, I suggest they try creating the same report from scratch (from the Reports menu) to see if that works.

    If only "saved" reports are being affected, that may well be the long known saved reports problem (rather than a "match" problem); corrupted saved reports can be overcome by re-creating the saved report from scratch.

    -JP

    [Merged Post]

    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the Quicken Windows FAQ list

  • littlebuffalo
    littlebuffalo Member
    edited September 2023

    mshiggins,

    Thank you. I have been a Quicken user since it first came out in circa 1983. I am curious about the saved reports. The report I have used for many years in my saved reports is called Categories and Payees Report. I cannot figure out how I even got this report or what report I customized. This is the most important report in my saved ones that will not work with match criteria. I have gone through all the template reports and nothing looks like this. The itemized categories and itemized payees comes close but I am not wanting those reports to sort or subtotal by categories or payees. I don't see anyway to customize by changing subtotals anymore. I attached a PDF of the customizing screen. I just noticed the new templates customization does not include a "headings" section.

    [Merged Post]

  • Joseph Witkin
    Joseph Witkin Member ✭✭✭✭
    edited September 2023

    I use "memo contains" to select the transactions for the report. I do not show a "memo contains" column in the report itself, as they would all be the same. Workaround not helpful in this situation?

    [Merged Post]

  • S. Weston
    S. Weston Member ✭✭✭

    Joseph Witkin - Add the memo column to the report for this workaround. The filter works by delivering results where the memo contains the entered text. So for other scenarios, they would not all be the exact same memo text. In any case, that's what you need to do to utlize this workaround.

  • Joseph Witkin
    Joseph Witkin Member ✭✭✭✭

    This is a bug - a setting that is offered but does not work. Quicken needs to fix it.

    I have reverted to version 51.12 - I do not need the workaround. But I would like to be able to take advantage of future updates that I am paying for.

  • Joseph Witkin
    Joseph Witkin Member ✭✭✭✭
    edited September 2023

    See also the thread "R52.19 - Banking Transaction Report not filtering on Memo". SInce version 52, multiple issues with saved report search criteria filters. I have seen no response from Quicken on that thread, though it is affecting many users.

    [Merged Post]

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited September 2023

    I agree that Quicken should fix this bug.

    The workaround is a way to use the current software that may help some users.

    QWin Premier subscription
  • Quicken Kristina
    Quicken Kristina Moderator mod
    edited September 2023

    Hello @Joseph Witkin,

    Thank you for joining the discussion. When I look up the thread you referenced, it looks like a moderator did post on September 8th.

    I hope this helps!

    [Merged Post]

    Quicken Kristina

    Make sure to sign up for the email digest to see a round up of your top posts.

  • Quicken Janean
    Quicken Janean Moderator admin

    Hi all, I am sorry for the issues with the memo field! I have reported this to our product development team. I do not have an ETA to provide in regard to a resolution. Please stay tuned and check back for any updates. Thank you for your patience.

    CTP-7772

    Quicken Janean

    Make sure to sign up for the email digest to see a round up of your top posts.

  • Joseph Witkin
    Joseph Witkin Member ✭✭✭✭

    Thank you for acknowledging that Quicken is aware of the issue! I am sure it will ultimately be resolved.

  • Joseph Witkin
    Joseph Witkin Member ✭✭✭✭
    edited September 2023

    Thank you!

    [Merged Post]

  • littlebuffalo
    littlebuffalo Member
    edited September 2023

    Quicken Kristina,

    I have been researching and experimenting on my issue and noticed several things. 1. It is true that the match criteria filter works on program report templates, however, it does not work on any saved reports. 2. Also, the match filters do not work on memorized payee reports. (Go to memorized payees and choose a payee and go to the far right of the line and click to generate a report.) 3. Also, unrelated to the match filter issue, reports no longer keep the resizing of columns after the report is created and then you go into a transaction and then back to the report.

    I understand you have suggested clicking on help and report a problem. I feel as though I have done a good job on this discussion post explaining the issue. I am not comfortable submitting a so called "sanitized file". I am however willing to discuss the issue with a support staff on the phone or perhaps do a screen share with a staff person to demonstrate the problem.

    [Merged Post]

This discussion has been closed.