Can not add new subcategories to any category --> need to delete bogus entry (edit)

Options
BlackDuck2
BlackDuck2 Member ✭✭
Hello, I am trying to add a new subcategory under an expense category. I cannot do this because in the "subcategory of" dropdown box, I am only being shown income categories as options for parent categories. I cannot find a way to make this work. I did not have this problem until I ran a file validation. Can anyone help? Running the latest version of Quicken for Windows on Win 11.
Tagged:
«1

Answers

  • splasher
    splasher SuperUser ✭✭✭✭✭
    Options
    Please confirm your release of Quicken at Help->About Quicken since it could be either R46.12 or R47.7 depending if you have the latest staged release.  "Latest" is not definitive enough the way Quicken does releases.

    -splasher using Q continuously since 1996
    - Subscription Quicken - Win11 and QW2013 - Win11
    -Questions? Check out the Quicken Windows FAQ list

  • BlackDuck2
    BlackDuck2 Member ✭✭
    Options
    R47.7 is my version. I just restored a backup, and I can now add subcategories again. I do not know what happened when I did the validation. The validation operation repaired some errors, but I didn't keep a copy of the validation log. Is there a way to see the log file?
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser ✭✭✭✭✭
    Options
    The log is %APPDATA%\Quicken\Log\DATA_LOG.TXT and most recent entries are at the bottom.

    Quicken user since version 2 for DOS, now using QWin Biz & Personal Subscription (US) on Win10 Pro.

  • ChrisMK
    ChrisMK Member ✭✭
    Options
    I am having the same issue. The dialogue box is only showing some of my Income categories. I added sub-categories recently. I am running R46.12 Build 27.1.46.12

    Please Help ASAP
  • BlackDuck2
    BlackDuck2 Member ✭✭
    edited January 2023
    Options
    Hello Chris- so I found in my validation log that some of the business expense group categories had been changed to the personal expense group because I had not assigned a tax form to the category before running the validation. But I still don’t know why I was unable to add a subcategory under ANY expense category— like you, I was only being given income categories in the drop down box. And these were business expense categories with the correct group and tax form, as well as personal expense categories. The only way I fixed it was to restore a backup.
  • ChrisMK
    ChrisMK Member ✭✭
    Options
    Hi BlackDuck2 - I just finished a chat session. I have a ticket number and i am supposed to get a call back tomorrow. They had me run a super validation (in addition to normal). Still did not fix the issue.
  • BlackDuck2
    BlackDuck2 Member ✭✭
    Options
    Thank you for the update, ChrisMK. I hope you get it fixed; I've never had a problem like this before in Quicken. Please update here if you figure this out, and I will do the same. I am going to try the following: back up my file, run the validation again, see if the subcategory issue happens again, then I will look at the log file again and try to see if that shows anything. Good luck!
  • ChrisMK
    ChrisMK Member ✭✭
    Options
    Hi BlackDuck2 - I think I resolved my issue. I upgraded manually to version r47.7 (see link below). I looked at my expense categories via the Tools menu pick and filtered on expenses only. I noticed a category that I never had in the past (and I don't remember adding it) with zero entries. It was the first expense category and named ACCT_3a84. I deleted it and now I can add subcategories like normal !! Good luck.

    manual update link
    https://www.quicken.com/support/update-and-patch-20182019-release-quicken-windows-subscription-product
  • BlackDuck2
    BlackDuck2 Member ✭✭
    Options
    After reading your comment, I remembered I saw a weird category with no entries that I never created named ACCT_15706 that appeared after I ran the validation in my original Quicken file (not the restored backup that is working). I re-opened that original Quicken file, deleted that weird ACCT_15706 category, and now the subcategory feature is working again!! Thank you so much for your help. Next time, I will not ignore weird accounts or categories that show up randomly! Thanks so much!
  • BlackDuck2
    BlackDuck2 Member ✭✭
    Options
    This is what the log file looked like after I ran the validation on my Quicken file:

    QDF:
    Validating your data.
    Quicken repaired damaged transaction index. No action required.
    Quicken found an invalid transaction and removed it. "ACCT_15706" 0/ 0/1900
    Quicken repaired some transaction information. No action required.
    "ACCT_15706" 0/ 0/1900
    Quicken found an invalid transaction and removed it. "ACCT_15706" 0/ 0/1900
    Quicken repaired some transaction information. No action required.
    "ACCT_15706" 0/ 0/1900

    Summary:
    Quicken repaired 1 accounts. No action required.


    After the validation, a new category named ACCT_15706 had been created by the process. After deleting this category, I was able to add subcategories again under expense categories.
  • johnthewonderful
    Options
    Same problem. Ran the Validate and Repair. No errors found. Problem remains.

    Also finally located the source of an error in the Budget facility. (Quicken confirmed.) Any amount entered into the (default) Everything Else Budget amount is not added into the Expense Balance Total. It is added to the overall Budget Balance Total,
  • jtakarsh
    jtakarsh Member
    Options
    Had a similar problem. Could not added a subcategory and the list of subcategories only include some categories, not all. In the category list there was a category ACCT_######. After removing the category, I was able to create a subcategory.
  • Robert
    Robert Member ✭✭✭
    Options
    Same problem.   I like to track major expense categories on each vacation.    I'm currently in Middle East and have subcategories like "Vacation:MiddleEast:Air".  Now I'm trying to create one for "Dining" and one for "Hotels" and I can't.   When I try to add them as a subcategories, the pull-down menu seem to end with one's that start with the letter S (such as a category for my daughter whose name starts with S.  Running Win10, Quicken R47.15 (which Quicken forced on me even though I prefer to wait 2-3 weeks to make sure the bugs are removed). 
  • splasher
    splasher SuperUser ✭✭✭✭✭
    Options
    Robert said:
    Same problem.   I like to track major expense categories on each vacation.    I'm currently in Middle East and have subcategories like "Vacation:MiddleEast:Air".  Now I'm trying to create one for "Dining" and one for "Hotels" and I can't.   When I try to add them as a subcategories, the pull-down menu seem to end with one's that start with the letter S (such as a category for my daughter whose name starts with S.  Running Win10, Quicken R47.15 (which Quicken forced on me even though I prefer to wait 2-3 weeks to make sure the bugs are removed). 
    I'd like to suggest using Tags.  Your category would be "Vacation:Air", the Tag would be "MiddleEast".  You would have less categories and by pulling a report by Tag, you could see all of the transactions of the "MiddleEast" trip whether they were for food, lodging, travel, gas, etc.
    Doing your way just makes your Categories explode exponentially and you have to create a bunch of them each trip/vacation, whereas if you use Tags, you only need to create one Tag for each excursion.
    You can also have more than one Tag on a transaction, so that the gas you bought could be tagged as "Beach Trip 2022" and "Toyota Camry" allowing you to see all the expenses of the Trip or how much your car is costing you to keep/use.

    -splasher using Q continuously since 1996
    - Subscription Quicken - Win11 and QW2013 - Win11
    -Questions? Check out the Quicken Windows FAQ list

  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    Options
    It's possible there is a way around the problem, but since none of my Quicken files has the problem, I can't verify whether this will work.

    In the Category List, right-click the category you want to create a sub-category for. 

    In the resulting dropdown menu, select "New subcategory". The "New Category" dialog will open with the parent-category-to-be already selected in the "Subcategory of" dropdown. Then you can just enter the name of the new sub-category in the Category Name field and click OK.

    -JP

    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the Quicken Windows FAQ list

  • Robert
    Robert Member ✭✭✭
    Options
    mshiggins said:
    It's possible there is a way around the problem, but since none of my Quicken files has the problem, I can't verify whether this will work.

    In the Category List, right-click the category you want to create a sub-category for. 

    In the resulting dropdown menu, select "New subcategory". The "New Category" dialog will open with the parent-category-to-be already selected in the "Subcategory of" dropdown. Then you can just enter the name of the new sub-category in the Category Name field and click OK.

    -JP


    No love for me.   I tried your workaround.  It works with categories early in the alphabet so I could add a "test" category to "Auto:Fuel" to create "Auto:Fuel:Test".  And as you said, the subcategory autopopulated.   But when I went to "Vacation:MiddleEast" and tried to add "Dining" the subcategory did NOT autopopulate and the subcategory list stopped in the S's.   I know I have a lot of categories (some of which I haven't used for years, but this was working when I booked air travel in december and one of the upgrades broke it.
  • Robert
    Robert Member ✭✭✭
    Options
    My guess is that 47.15 broke this as I was able to create subcategories withing "Vacation:MiddleEast" as late as first week of February.   Supposedly 47.15 fixed a problem displaying categories for some people, but it seems to have broken subcategory creation.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Options
    Robert said:
    My guess is that 47.15 broke this as I was able to create subcategories withing "Vacation:MiddleEast" as late as first week of February.   Supposedly 47.15 fixed a problem displaying categories for some people, but it seems to have broken subcategory creation.
    @robert ,
    as suggested by others in this discussion, have you reviewed your Tools / Category List for entries named similar to "ACCT_xxxx"? If this phantom category exists, it's most likely to cause a broken chain in the database table. Deleting it is supposed to resolve the issue with popup selection lists terminating prematurely.

  • Robert
    Robert Member ✭✭✭
    Options
    UKR said:
    Robert said:
    My guess is that 47.15 broke this as I was able to create subcategories withing "Vacation:MiddleEast" as late as first week of February.   Supposedly 47.15 fixed a problem displaying categories for some people, but it seems to have broken subcategory creation.
    @robert ,
    as suggested by others in this discussion, have you reviewed your Tools / Category List for entries named similar to "ACCT_xxxx"? If this phantom category exists, it's most likely to cause a broken chain in the database table. Deleting it is supposed to resolve the issue with popup selection lists terminating prematurely.


    Nope.   no "ACCT_xxxx".   I had this maybe 6 months ago, but rebuilt my file and it cleaned it all up.   I've done supervalidate and it came out clean.   And keep in mind (if you read this entire thread) that I'm not the only one with this problem.   As usual, I was having the problem and I search google and found this thread which showed this is larger than just my file.   I'm in the Middle East now (today Israel, Friday Egypt) and don't have time to call quicken, but it would be nice if someone from Quicken would acknowledge this as a problem being worked on.
  • DeepShadow13
    Options
    > @BlackDuck2 said:
    > After reading your comment, I remembered I saw a weird category with no entries that I never created named ACCT_15706 that appeared after I ran the validation in my original Quicken file (not the restored backup that is working). I re-opened that original Quicken file, deleted that weird ACCT_15706 category, and now the subcategory feature is working again!! Thank you so much for your help. Next time, I will not ignore weird accounts or categories that show up randomly! Thanks so much!

    You are a lifesaver! I couldn't figure out why I couldn't add any new subcategories. Turns out I had a category named ACCT_fa3 at the top. Once I deleted it, I was able to add a subcategory with the dropdown fully populated.
  • Steven
    Steven Member ✭✭✭
    Options
    FWIW, in my case the bogus category was not ACCT_####, it was a category with the same name as an existing, valid account.

    For me the corruption started mid-January though I didn't detect it until February.

    I am able to reproduce the problem by going back to the undamaged files from that day and running validate. The validate report said it corrected a damaged category and (apparently) damaged the file. After that validate, the category list was broken.

    It looks like the dialog drop downs will tell you where to look for the bogus category: the last category in the dropdown is (probably?) the category right before the damaged category in the category list (ignoring accounts).

    I pretty much a super validate every day. I learned that from the "Corrected 1 Bought or Shares Added transaction that was incorrectly categorized as a realized gain." fiasco which Quicken has never fixed (but isn't causing me any big problems). But I didn't notice the one very short line in the repair back in January. I guess I'll have to be doubly careful. Sigh.
  • Quicken Janean
    Quicken Janean Moderator admin
    Options

    Hi All, I am sorry for the trouble caused. Can you please provide a sanitized file along with screenshot of the issue by going to Help> Report a Problem? This would be helpful to our developers so they are able to determine why this issue is happening. Thanks!

    -Quicken Janean

    Quicken Janean

    Make sure to sign up for the email digest to see a round up of your top posts.

  • davidraby
    davidraby Member
    Options

    Quicken Team…we can't create subcategories. Please fix this ASAP.

  • Quicken Kristina
    Quicken Kristina Moderator mod
    edited March 2023
    Options

    Hello @davidraby,

    Thank you for reaching out to the Community and telling us about this issue.  I'm sorry to hear you're running into this problem. If you don't mind, would you please provide a sanitized file along with screenshot of the issue by going to Help> Report a Problem? This would be helpful to our developers so they are able to determine why this issue is happening.

    Also, one thing that has worked for others running into this issue is to go to Tools>Category List and see if you can find a category that does not belong and you know you did not add. Some reported seeing a category in the format of ACCT_#### while others said it was different, such as a duplicate of an existing category. Finding and deleting that category has corrected the issue for others, so I would recommend giving it a try.

    Thank you.

    Quicken Kristina

    Make sure to sign up for the email digest to see a round up of your top posts.

  • Ps56k2
    Ps56k2 Alumni ✭✭✭✭
    Options

    did you read the rest of the postings -
    do you have some kind of "bogus" Category that might have been created by Quicken
    or by the Validate & Repair function ?

  • mancuj1
    mancuj1 Member ✭✭
    Options

    Having the same issue, and don't have any ACCT_#### categories. This needs to be fixed ASAP

  • Robert
    Robert Member ✭✭✭
    Options

    Still having this problem. Spent well over an hour (very frustrating) on phone with L1 support who spent most of the time on chat with L2 trying to come up with things for me to try to solve the problem. Nothing worked. Finally got totally frustrated and agent said he'd call me back later after working more with L2. I clearly showed him the problem (can't add subcategories on any category starting with letter T or higher in alphabet. If Category starts with A-S, adding subcategories works fine). Problem started with R47.15 which is the release that fixed category display in budgets for some people (I did not have that problem), but created a new problem creating subcategories. So frustrating. I asked if I could set up a call with L2 and agent said not possible (even though I've done it before).

  • BlackDuck2
    BlackDuck2 Member ✭✭
    Options
    > @Robert said:
    > Still having this problem. Spent well over an hour (very frustrating) on phone with L1 support who spent most of the time on chat with L2 trying to come up with things for me to try to solve the problem. Nothing worked. Finally got totally frustrated and agent said he'd call me back later after working more with L2. I clearly showed him the problem (can't add subcategories on any category starting with letter T or higher in alphabet. If Category starts with A-S, adding subcategories works fine). Problem started with R47.15 which is the release that fixed category display in budgets for some people (I did not have that problem), but created a new problem creating subcategories. So frustrating. I asked if I could set up a call with L2 and agent said not possible (even though I've done it before).

    Hi Robert, if you go through your account list, see if you can find an account that has a nonsense name, like ACCT_3a84 or ACCT_15706 that you did not create, and delete it. This solved my problem.
  • Robert
    Robert Member ✭✭✭
    Options

    I do not have any "nonsense account" starting with ACCT_#### or anything that looks suspicious. Validate and Supervalidate results in nothing at all. File is clean as best I can tell. I have a lot of categories/subcategories (slightly over 700) but this is not new and everything worked until R47.15 and later releases.

  • Steven
    Steven Member ✭✭✭
    Options
    Did you see my comment above? I didn't have a category with a bogus name either: I had a category with the same name as an account.

    When you try to add a category and make it a subcategory, does it offer any categories to make a subcategory of, in other words, a short, incomplete list? That was what I had. I took note of the last category it listed and then when to the category list. Looking at the category list, I found that the next category (not account, since the category list shows both) was bogus: it was named the same as an account so there was both the account and the category in the category list. I deleted the category (kept that account, which was valid) and it fixed the the problem.

    On the other hand, if you don't get prompted for any categories when you try to create a subcategory and/or there's no category-account double, my experience isn't of any help.
This discussion has been closed.