Return of Capital should not be "Not Categorized" transaction (20 Legacy Votes)

Joseph Arden
Joseph Arden Member ✭✭
edited August 2019 in Investments (Windows)
Currently, Return of Capital shows up as a Not Categorized transaction. This is a problem when running and Income/Expense reports as I don't want to see Return of Capital as Income... It's not income! It's converting one asset to another asset. I could run the report excluding Not Categorized transactions but I actually want to see Not Categorized transactions in my report. Instead, it would make most sense to either allow the user to categorize Return of Capital transactions OR auto-categorize as a different category (e.g. "Return of Capital"). This way a user can exclude "Return of Capital" and still see all Not Categorized transactions.
1
1 votes

No Status · Last Updated

Comments

  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    edited May 2018
    Seems to me a "damned if you do, damned if you don't" conundrum.  That is, if you create a new 'category' for those transactions, the category will be either an income or expense category, and as you noted, Return of capital is neither.  All Quicken categories fit the income/expense mold, so that does not seem to be a solution to me.  

    My workaround would be to use a suitable keyword in the memo field.  I commonly use RtrnCap transactions for bond premium amortization, and those transactions always include the keyword 'amortization' in the memo field.  I can eliminate those transactions from a report by customizing the 'categories' tab of the report and choosing to exclude those transactions using the leading tilde ~ on the keyword for the memo field.  See pic.
     
     image

    "Amort" in the "Memo contains" field would report only those transactions.
    "~Amort" in the field excludes all such transactions.  

    HTH
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    edited December 2016
    q.lurker said:

    Seems to me a "damned if you do, damned if you don't" conundrum.  That is, if you create a new 'category' for those transactions, the category will be either an income or expense category, and as you noted, Return of capital is neither.  All Quicken categories fit the income/expense mold, so that does not seem to be a solution to me.  

    My workaround would be to use a suitable keyword in the memo field.  I commonly use RtrnCap transactions for bond premium amortization, and those transactions always include the keyword 'amortization' in the memo field.  I can eliminate those transactions from a report by customizing the 'categories' tab of the report and choosing to exclude those transactions using the leading tilde ~ on the keyword for the memo field.  See pic.
     
     image

    "Amort" in the "Memo contains" field would report only those transactions.
    "~Amort" in the field excludes all such transactions.  

    HTH

    Just pointing out this is a QWin solution. I'm not sure QMac even has a Return of Capital transaction type and if so, how that transaction would be presented in reports.
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • Joseph Arden
    Joseph Arden Member ✭✭
    edited November 2016
    q.lurker said:

    Seems to me a "damned if you do, damned if you don't" conundrum.  That is, if you create a new 'category' for those transactions, the category will be either an income or expense category, and as you noted, Return of capital is neither.  All Quicken categories fit the income/expense mold, so that does not seem to be a solution to me.  

    My workaround would be to use a suitable keyword in the memo field.  I commonly use RtrnCap transactions for bond premium amortization, and those transactions always include the keyword 'amortization' in the memo field.  I can eliminate those transactions from a report by customizing the 'categories' tab of the report and choosing to exclude those transactions using the leading tilde ~ on the keyword for the memo field.  See pic.
     
     image

    "Amort" in the "Memo contains" field would report only those transactions.
    "~Amort" in the field excludes all such transactions.  

    HTH

    That is why I created this as an "Idea". It's not perfect, however, if Return of Capital was always categorized as "Return of Capital", then I could create a permanent Income/Expense report that excludes that category. Of course, if Quicken "auto-categorized" Return of Capital transactions as "Return of Capital", then they could default the Income/Expense report to exclude that category. 

    Your work around is fine... in the end, it's still a workaround and requires me to ensure I correctly add a memo to ensure it works. Good for short term, not so good for long term.
  • Joseph Arden
    Joseph Arden Member ✭✭
    edited November 2016
    q.lurker said:

    Seems to me a "damned if you do, damned if you don't" conundrum.  That is, if you create a new 'category' for those transactions, the category will be either an income or expense category, and as you noted, Return of capital is neither.  All Quicken categories fit the income/expense mold, so that does not seem to be a solution to me.  

    My workaround would be to use a suitable keyword in the memo field.  I commonly use RtrnCap transactions for bond premium amortization, and those transactions always include the keyword 'amortization' in the memo field.  I can eliminate those transactions from a report by customizing the 'categories' tab of the report and choosing to exclude those transactions using the leading tilde ~ on the keyword for the memo field.  See pic.
     
     image

    "Amort" in the "Memo contains" field would report only those transactions.
    "~Amort" in the field excludes all such transactions.  

    HTH

    Also.. thanks for quick response!
  • John_in_NC
    John_in_NC SuperUser, Mac Beta Beta
    edited December 2016
    q.lurker said:

    Seems to me a "damned if you do, damned if you don't" conundrum.  That is, if you create a new 'category' for those transactions, the category will be either an income or expense category, and as you noted, Return of capital is neither.  All Quicken categories fit the income/expense mold, so that does not seem to be a solution to me.  

    My workaround would be to use a suitable keyword in the memo field.  I commonly use RtrnCap transactions for bond premium amortization, and those transactions always include the keyword 'amortization' in the memo field.  I can eliminate those transactions from a report by customizing the 'categories' tab of the report and choosing to exclude those transactions using the leading tilde ~ on the keyword for the memo field.  See pic.
     
     image

    "Amort" in the "Memo contains" field would report only those transactions.
    "~Amort" in the field excludes all such transactions.  

    HTH

    There is a Return of Capital transaction type. One question: do you allow it to use the Description: Investment:Return of Capital? (That acts as the category field. I don't know if you have the Description column showing, but it should default to that. That category isn't set to income or expense.

    If you do this, you should see the ROC transactions on things like your category summary reports.

    image
  • Joseph Arden
    Joseph Arden Member ✭✭
    edited November 2016
    q.lurker said:

    Seems to me a "damned if you do, damned if you don't" conundrum.  That is, if you create a new 'category' for those transactions, the category will be either an income or expense category, and as you noted, Return of capital is neither.  All Quicken categories fit the income/expense mold, so that does not seem to be a solution to me.  

    My workaround would be to use a suitable keyword in the memo field.  I commonly use RtrnCap transactions for bond premium amortization, and those transactions always include the keyword 'amortization' in the memo field.  I can eliminate those transactions from a report by customizing the 'categories' tab of the report and choosing to exclude those transactions using the leading tilde ~ on the keyword for the memo field.  See pic.
     
     image

    "Amort" in the "Memo contains" field would report only those transactions.
    "~Amort" in the field excludes all such transactions.  

    HTH

    I am using the Return of Capital transaction Type. There is a memo field available which does not affect the categorization. Basically, I just want to be able to assign a valid category to a Return of Capital transaction. This way I can choose to include or exclude the transaction from various reports. For example, on the Cash Flow report, Return of Capital transactions show up as Uncategorized INFLOWS. This means the transactions are bundled with other uncategorized transactions. I don't want this. I want to unbundle Return of Capital transactions.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    edited December 2016
    q.lurker said:

    Seems to me a "damned if you do, damned if you don't" conundrum.  That is, if you create a new 'category' for those transactions, the category will be either an income or expense category, and as you noted, Return of capital is neither.  All Quicken categories fit the income/expense mold, so that does not seem to be a solution to me.  

    My workaround would be to use a suitable keyword in the memo field.  I commonly use RtrnCap transactions for bond premium amortization, and those transactions always include the keyword 'amortization' in the memo field.  I can eliminate those transactions from a report by customizing the 'categories' tab of the report and choosing to exclude those transactions using the leading tilde ~ on the keyword for the memo field.  See pic.
     
     image

    "Amort" in the "Memo contains" field would report only those transactions.
    "~Amort" in the field excludes all such transactions.  

    HTH

    I believe the original comment was Windows based.  How that consideration applies to the Mac side, I have no idea.  In principle, the two should be parallel in this aspect (or so it seems to me).  But I would not force that into the Idea presented at this time.  

    (IMO, this discussion should have only been categorized in this forum to the Win Investment side.  But that too is my reading between the lines.)
  • John_in_NC
    John_in_NC SuperUser, Mac Beta Beta
    edited December 2016
    q.lurker said:

    Seems to me a "damned if you do, damned if you don't" conundrum.  That is, if you create a new 'category' for those transactions, the category will be either an income or expense category, and as you noted, Return of capital is neither.  All Quicken categories fit the income/expense mold, so that does not seem to be a solution to me.  

    My workaround would be to use a suitable keyword in the memo field.  I commonly use RtrnCap transactions for bond premium amortization, and those transactions always include the keyword 'amortization' in the memo field.  I can eliminate those transactions from a report by customizing the 'categories' tab of the report and choosing to exclude those transactions using the leading tilde ~ on the keyword for the memo field.  See pic.
     
     image

    "Amort" in the "Memo contains" field would report only those transactions.
    "~Amort" in the field excludes all such transactions.  

    HTH

    It got categorized as a Mac investment question. Whether or not it should be, I now don't know.
  • Joseph Arden
    Joseph Arden Member ✭✭
    edited November 2016
    q.lurker said:

    Seems to me a "damned if you do, damned if you don't" conundrum.  That is, if you create a new 'category' for those transactions, the category will be either an income or expense category, and as you noted, Return of capital is neither.  All Quicken categories fit the income/expense mold, so that does not seem to be a solution to me.  

    My workaround would be to use a suitable keyword in the memo field.  I commonly use RtrnCap transactions for bond premium amortization, and those transactions always include the keyword 'amortization' in the memo field.  I can eliminate those transactions from a report by customizing the 'categories' tab of the report and choosing to exclude those transactions using the leading tilde ~ on the keyword for the memo field.  See pic.
     
     image

    "Amort" in the "Memo contains" field would report only those transactions.
    "~Amort" in the field excludes all such transactions.  

    HTH

    You are correct. It is window based. I am assuming the problem is independent of Mac/Win and, regardless, the idea should apply to both platforms.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    edited December 2016
    q.lurker said:

    Seems to me a "damned if you do, damned if you don't" conundrum.  That is, if you create a new 'category' for those transactions, the category will be either an income or expense category, and as you noted, Return of capital is neither.  All Quicken categories fit the income/expense mold, so that does not seem to be a solution to me.  

    My workaround would be to use a suitable keyword in the memo field.  I commonly use RtrnCap transactions for bond premium amortization, and those transactions always include the keyword 'amortization' in the memo field.  I can eliminate those transactions from a report by customizing the 'categories' tab of the report and choosing to exclude those transactions using the leading tilde ~ on the keyword for the memo field.  See pic.
     
     image

    "Amort" in the "Memo contains" field would report only those transactions.
    "~Amort" in the field excludes all such transactions.  

    HTH

    I would not assume that QMac reports the transactions in the same style that QWin does as evidenced by John's one-line example.  That is, QMac may not demonstrate the same anomaly as QWin does with respect to lumping RtrnCap transactions with other Uncategorized transactions.  If QMac behaves differently, the Idea may not apply to that version.    
  • M C Crockett
    M C Crockett Member ✭✭✭
    edited December 2016
    q.lurker said:

    Seems to me a "damned if you do, damned if you don't" conundrum.  That is, if you create a new 'category' for those transactions, the category will be either an income or expense category, and as you noted, Return of capital is neither.  All Quicken categories fit the income/expense mold, so that does not seem to be a solution to me.  

    My workaround would be to use a suitable keyword in the memo field.  I commonly use RtrnCap transactions for bond premium amortization, and those transactions always include the keyword 'amortization' in the memo field.  I can eliminate those transactions from a report by customizing the 'categories' tab of the report and choosing to exclude those transactions using the leading tilde ~ on the keyword for the memo field.  See pic.
     
     image

    "Amort" in the "Memo contains" field would report only those transactions.
    "~Amort" in the field excludes all such transactions.  

    HTH

    Perhaps, I'm doing something wrong as all my Return of Capital type transactions in QM2017 have their Description and Category fields set to "Investments:Return of Capital".  This is a "Required" category in the Categories List and does not have either the Expense or Income selectors set.

    QM2017 does adjust the cost (tax) basis of the shares held albeit incorrectly when the Return of Capital dividend is reinvested in the security.  QM2017 includes the shares that were acquired with the Return of Capital dividend to calculate the per share Return of Capital.  The gains and losses reported in Portfolio > Realized Gain and Schedule D of the Tax Schedule reports are wrong as a result.

    "Investments:Return of Capital" never appears in the Category Summary report even after you have selected it to be included.  If selected, it will be reported in a Category Comparison report but will only be included in the Other section of the report as it is neither an Expense or Income.

    Of course, I may have developed a habit of setting "Investments:Return of Capital" in the Description or Category field when I learn that a dividend is a Return of Capital or import my QWIN data into QMAC as part of my review process.  I'll have to wait until the end of January when my next dividend is due to find out.
  • Quicken Anja
    Quicken Anja Moderator mod
    Hello All,

    The Community Support team regularly reviews long-standing posts and Ideas for relevancy and current interest. This Idea seems to have stalled and we would like to gauge the current interest in this request. 

    If you would like to see this idea implemented, please add your vote and a comment explaining how this idea would be beneficial for you. More information, including steps to vote and how to submit your own Ideas for future product features/improvements, is also available here.

    Thank you,

    Quicken Community Support Team
    -Quicken Anja
Sign In or Register to comment.