First Progress Mastercard charges appear as payments, payments as charges

First Progress MasterCard charges appear as payments, payments as charges, OK [other platforms].
Quicken blames the bank but the charges are correct in [other platforms] The transactions are download but in the wrong order. Quicken has so far refused to fix this. I can use [other platforms] but not Quicken for these Transactions so far. I would prefer if Quicken would fix this, I wonder what it takes to get Quicken to fix this?

Best Answers

  • alannsandiego
    alannsandiego Member ✭✭
    Accepted Answer
    The previous post is how First Progress MasterCard downloads, with the beginning balance corrected Here the end balance is correct, Only the Sign of the Charges needs to be changed from Positive on the website to negative for download into Quicken and the Payments negative needs to be changed to Positive for download into Quicken and then the balance is correct.
    Quicken_Tyka Moderator mod was helping me she said she ask another moderator to help me,
    she not available until Thursday now.
  • Quicken Sarah
    Quicken Sarah Administrator, Moderator mod
    edited June 2 Accepted Answer
    NotACPA said:
    There is NOTHING in this unnecessarily lengthy post that shows the <TRNAMT> field.  So your claim that the bank is sending it properly is unsupported.
    Try saving a downloaded QFX file and extracting from that.  You could also try looking in the OFX Log.
    Here's an example of such a debit transaction "<TRNAMT>-600.00" actually sent by my bank.


    Hello @NotACPA

    Thank you for your interest in this post.  I can confirm that we are investigating this issue and I have reviewed the log files and verified the financial institution is sending the amounts correctly and we are investigating further as a possible bug in Quicken.

    I'll be back to share any updates and/or the ticket number as they become available.

    Sarah
  • alannsandiego
    alannsandiego Member ✭✭
    edited June 2 Accepted Answer
  • alannsandiego
    alannsandiego Member ✭✭
    Accepted Answer
    First Progress downloads the transaction exactly like their website, the amount of the transactions are correct but the sign (+) (-) of the data is wrong; charges must be negative numbers in Quicken Credit card accounts, and payments must be positive numbers in Quicken Credit card accounts. First Progress MasterCard is a credit card processing company and they seem to be unaware of their Online Banking Provider so I cannot ask the "Bank" to fix this they are not a "Bank". I have written a letter to First Progress MasterCard, but I expect them to respond that Quicken is a third party program they do not support Quicken; which is funny because it almost works! I do know why Quicken claims to support them, I think that Quicken used to have a contract with them but do not have one presently.

    If First Progress has a contract with Intuit or an Online Banking provider, this problem can easily be fixed with (* -1) of the data.

    Quicken has open a ticket but that is not solving the problem. One solution would be for Quicken program itself to check the sign (+) (-) of the data when it is input into Quicken and change it if is wrong, or have an option to do that.

    It seem more likely to me that First Progress MasterCard does not have a contract with Intuit and that is the reason the problem is not being fix. For now the data has to manually corrected charges move manually from payment to charges, and payments moved from charges to payment; almost the same as doing it manually in the first place.

    So right now, First Progress MasterCard is not actually supported by Quicken, because it does not work correctly, maybe a ticket open but no ETA if ever gets fix; that is the same as not supported.

    https://www.intuit.com/partners/fdp/implementation-support/ofx/get-a-quote-tool/
    Participation Fee Due ? Annual Version Fee $33,000
    Intuit charges "Banks" at least $10,000 per year for a contract.

    https://www.intuit.com/partners/fdp/implementation-support/ofx/why-connect/connectivity-types/
    Express Web Connect - contract with your OFX/Online Banking Provider might be required

    Express Web Connect is the second of two automatic update options. Unlike Direct Connect which communicates directly with your OFX servers, Express Web Connect utilizes aggregation to retrieve transactions from your online banking site. Intuit creates and manages this connectivity type when you have a contracted Web Connect or Direct Connect BID. Please check with your OFX/Online Banking Provider to make sure aggregation is supported by your OLB site.

    Since the transaction data does download correctly as it is on First Progress MasterCard Website, appearently Quicken/ Intuit is connected otherwise it would not work at all; but with an incorrect sign (+) (-), the data is nearly useless.

    Apparently Quicken does not talk to Intuit about data errors, otherwise this could have been fixed already; and I do not have time to manually correct the data that is what I paying Quicken to do.
«1

Answers

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Please go to Tools > Account list. Click on Options at the bottom of the list and check Show transaction download status if if is not already selected.

    Then next to the problem account, what does it show as the (connection method)? 

    What do you mean by "The transactions are downloaded in the wrong order"? If you would like to see the newest transactions at the bottom of the list rather than the top, click repeatedly on the Date column header until there is a little triangle and it points up. 
    QWin Premier subscription
  • alannsandiego
    alannsandiego Member ✭✭
    The connection type is Express Web Connect. Charges are not Payments and Payments are not Charges.
    I checked that First Progress MasterCard supported Quicken before I applied for the credit card and Quicken does download the transactions; but Charges are Not Payments and Payments are not Charges. A 10 dollars charge shows as a 10 dollars payment, maybe the wrong order bad wording; but it matters whether you owe or have a credit on the credit card both for the account and spending as a whole.
    The transactions are correct in Mint https://mint.intuit.com/ Mint uses the same download interface as Quicken that is not working correctly. The transactions are download but in the wrong order. Charges are not Payments and Payments are not Charges. Quicken has so far refused to fix this. Quicken not supporting their product again. This is a warning that Quicken unwilling to fix the transaction download for First Progress MasterCard so use another credit card until they fix it, if they ever do so?
  • alannsandiego
    alannsandiego Member ✭✭
    Only Quicken can fix this issue far as I can tell. All my other credit cards work just fine. This is a new credit card that did not work correctly since if was setup. I had to delete the account because the charges showing up as payments damages Quicken budget by reporting the wrong totals.
  • alannsandiego
    alannsandiego Member ✭✭
    edited May 27
    [Removed-No Soliciting]
  • volvogirl
    volvogirl SuperUser ✭✭✭✭
    Are the transactions showing up in the wrong column or is just the balance going the wrong way?  Like a charge reduces the balance instead of increasing it.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Almost 100% of the people reporting that charges and payments are reverse fall into two categories.

    The first being that the register is sorted/filtered wrong.  If are sorting by anything other than the date or if you filter out certain transactions you can cause Quicken to total up transactions either out of date of be leaving out transactions that ensure the total even make sense in the terms of what your balance at your financial institution would be (like displaying only uncategorized transactions).
    For this selecting the Reset button at the top of the register should fix it.

    The second problem happens when the account balance turns positive for some reason.  The reason might be a missing transaction or if the user really does have a positive balance (over paying their bill).  In this case you will see charges entered as positive/black values, which is in fact correct (the balance is positive/black, charge and payment columns are always positive).  The fix is to find out what is missing/added that made the balance go positive in the first place.  Here is an example.


    If I turn on the Amount column it is a bit easier to see what is in fact entered.


    There is a very outside chance that in fact the charges/payments are being downloaded incorrectly.
    And the Amount column would make that very clear if it is true (a screenshot of a few of your transactions like I have above would confirm it).

    If that is the case then the problem is in fact going to be how the Intuit servers are collecting the data from the financial institution's website.  Quicken Inc pays Intuit for the Express Web Connect service.
    This wouldn't be a generic problem in Quicken.  This should be reported to Quicken Support so that they can work with Intuit and the financial institution to get the problem fixed.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    P.S. Quicken Support Link: Contact Quicken Support
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • alannsandiego
    alannsandiego Member ✭✭
    The charges are download as a positive number, when in a normal account it is negative number.
    There is no filter set. this account only open 21 days, it has been broken since setup. Payment download as a negative number, when in a normal account it is a positive number. Yes the balance is wrong.
    I have already told Quicken Support and they refuse to fix it, I said they blame the Bank,
    First Progress says they do not support Quicken and they will not fix it, only Quicken can fix it.
    Does anyone know how to get Quicken to fix this? I already asked them myself.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Well what should have happened is Quicken Support should have taken the logs and escalated the problem so that it could be hashed out between Intuit and the financial institution of what needs to be fixed.

    I'm going to flag this thread to see if a moderator can help with that.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • alannsandiego
    alannsandiego Member ✭✭
    Express Web Connect - contract with your OFX/Online Banking Provider might be required

    Express Web Connect is the second of two automatic update options. Unlike Direct Connect which communicates directly with your OFX servers, Express Web Connect utilizes aggregation to retrieve transactions from your online banking site. Intuit creates and manages this connectivity type when you have a contracted Web Connect or Direct Connect BID. Please check with your OFX/Online Banking Provider to make sure aggregation is supported by your OLB site.

    Intuit creates and manages this connectivity type when you have a contracted Web Connect or Direct Connect BID. Intuit charge for these two: https://www.intuit.com/partners/fdp/implementation-support/ofx/get-a-quote-tool/

    First Progress does not have Web Connect or Direct Connect.

    Express Web Connect is downloading transaction but charges appear as payment likely because they download as positive number as they are on the First progress website, but charges should download as negative number to appear as charges, which is not happening.

    <INTU.MASTERID>67376
    </INTU.BIDINFO>
    <INTU.BRANDDETAILS>
    <INTU.BRANDNAME>First Progress Platinum MasterCd
    <INTU.STATUS>ACTIVE
    <INTU.NPCFLAG>OFX
    <INTU.MKTTIERTYPE>BANKING
    <INTU.MKTTIERCD>1
    <INTU.MKTDISTMETHOD>Retail
    <FI>
    <ORG>Customer Central
    <FID>67376
    </FI>
    <ADDR1>N/A
    <CITY>N/A
    <STATE>N/A
    <POSTALCODE>N/A
    <COUNTRY>USA
    <CSPHONE>N/A
    <URL>https://www.firstprogress.com/
    <INTU.FIPROFILEURL>Web Connect Only
    <INTU.SVCLIST>
    <INTU.SVC>CCSVC
    <INTU.SVC>ACCTINFOSVC
    </INTU.SVCLIST>
    <INTU.SPURLLIST>
    <INTU.SPURL>https://www.dummyspurl.com
    </INTU.SPURLLIST>
    <INTU.ENROLLURL>https://cc.firstprogress.com/login
    <INTU.BROWSERCENTRIC>
    <INTU.WEBFEATURENM>CCSTMTRS
    <INTU.ACCESSMETHOD>EXPRESS-WEBCONNECT
    <INTU.LOGINURL>https://fdatafeed-ccqd.platform.intuit.com/CustomerCentral/api
    <INTU.ACCESSURL>https://fdatafeed-ccqd.platform.intuit.com/CustomerCentral/api

    The bank is sending the information but Quicken is loading the information info Quicken wrong.
  • Quicken_Tyka
    Quicken_Tyka Alumni ✭✭✭✭
    Hello @alannsandiego

    I have sent you a direct message, please navigate to the inbox in the top right-hand corner of the Community page and check your inbox.



    Please respond to me via private message for further assistance.

    Thank you,
    -Quicken Tyka
    ~~~***~~~
  • Square26
    Square26 Member
    I am having the same problem, the individual charges from Capital One in my Visa account have always posted to Quicken as a negative number and each charge increased my balance owed.  Suddenly, on 3/16, my monthly payment resulted in a credit balance and after that point, each individual charge is being received still as a negative number but is reducing my balance owed.  This seems to be a Quicken issue rather than my credit card issuer's problem, and I would be grateful to have it corrected ASAP!

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    @alannsandiego It would have been helpful to see the part of the log where one of the transactions is with the wrong sign, but since @Quicken_Tyka is working with you directly I will assume that it will get iron out exactly where the problem is.

    Square26 said:
    I am having the same problem, the individual charges from Capital One in my Visa account have always posted to Quicken as a negative number and each charge increased my balance owed.  Suddenly, on 3/16, my monthly payment resulted in a credit balance and after that point, each individual charge is being received still as a negative number but is reducing my balance owed.  This seems to be a Quicken issue rather than my credit card issuer's problem, and I would be grateful to have it corrected ASAP!

    You have a different problem, and is something that need fixing in the Quicken program.
    Quicken is behaving exactly how it should when you have a credit card balance that is positive.
    Turning on the Amount column might make it easier for you to see.  Here is an example, I have purposely changed a transaction so that I have a positive credit card balance (as if the financial institution owes me money/over payment).


    You will notice that the color of the balance changed to black and the sign is positive.  In a credit card account unless you have over paid your balance it should always be red.  Once you have a positive balance then the balance is suppose to go down with every charge because you have less and less "over payment".

    What you need to do is find the transaction(s) that made your balance turn positive when it shouldn't have.

    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • alannsandiego
    alannsandiego Member ✭✭
    Square26 is having a different problem because if the charges are negative and the payments are positive the my balance correct. Except my beginning balance was not zero it has to be manually corrected.
    Please do not confuse my post with different issues, I waiting for Quicken to respond now.
    My problem is that With QFX only and taking the info off First Progress MasterCard website,
    the Charges are positive on their website and Payments are negative and so Quicken must Change the Sign of the Charges and Payment before downloading into Quicken.
  • alannsandiego
    alannsandiego Member ✭✭
    Here are pictures of First Progress website and Quickens postings.
  • alannsandiego
    alannsandiego Member ✭✭
    Accepted Answer
    The previous post is how First Progress MasterCard downloads, with the beginning balance corrected Here the end balance is correct, Only the Sign of the Charges needs to be changed from Positive on the website to negative for download into Quicken and the Payments negative needs to be changed to Positive for download into Quicken and then the balance is correct.
    Quicken_Tyka Moderator mod was helping me she said she ask another moderator to help me,
    she not available until Thursday now.
  • Quicken Francisco
    Quicken Francisco Moderator mod
    Hello @alannsandiego

    Thank you for taking the time to visit the Community to post your issue.

    I have sent you a direct message, please navigate to the inbox in the top right-hand corner of the Community page and check your inbox.


    Thank you,

    -Quicken Francisco

  • alannsandiego
    alannsandiego Member ✭✭
    Quicken has not offer to Escalate this issue to be fixed.<INTU.MASTERID>67376 <INTU.STATUS>ACTIVE
    Nothing wrong with my Quicken File or Setup, waiting for Quicken to Escalate this problem so it can be fixed. I have been though the troubleshooting steps four times now.

    Express Web Connect - contract with your OFX/Online Banking Provider might be required.
    If the Bank does not have a contract does Quicken support QFX only?

    The data is downloading there is only a small problem with the downloading into Quicken thru Express Web Connect, that should be easy to fix. (Change the sign of the charges and payment then balance would be correct)

    The main problem with First Progress MasterCard (they have QFX only) is the Charges are positive numbers on the website as on many websites like Capital One for example, but charges must download as a negative number to show up as charges in Quicken, and payment are negative number on the website as on many website again like Capital One, but payments must download a positive number to show up as payments. (Change the sign of the charges and payment then balance would be correct)

    First Progress does not have Web Connect or Direct Connect, but the data is downloading.
    Express Web Connect utilizes aggregation to retrieve transactions from your online banking site. Intuit creates and manages this connectivity type when you have a contracted Web Connect or Direct Connect BID. Please check with your OFX/Online Banking Provider to make sure aggregation is supported by your OLB site.

    Intuit creates and manages this connectivity type when you have a contracted Web Connect or Direct Connect BID. Intuit charges for these two: https://www.intuit.com/partners/fdp/implementation-support/ofx/get-a-quote-tool/ Intuit want $33,000 dollars for 3 years it looks like.

    First Progress does not have Web Connect or Direct Connect.

    <INTU.MASTERID>67376
    </INTU.BIDINFO>
    <INTU.BRANDDETAILS>
    <INTU.BRANDNAME>First Progress Platinum MasterCd
    <INTU.STATUS>ACTIVE
    <INTU.NPCFLAG>OFX
    <INTU.MKTTIERTYPE>BANKING
    <INTU.MKTTIERCD>1
    <INTU.MKTDISTMETHOD>Retail
    <FI>
    <ORG>Customer Central
    <FID>67376
    </FI>
    <ADDR1>N/A
    <CITY>N/A
    <STATE>N/A
    <POSTALCODE>N/A
    <COUNTRY>USA
    <CSPHONE>N/A
    <URL>https://www.firstprogress.com/
    <INTU.FIPROFILEURL>Web Connect Only

    Waiting for Escalations Support
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Have you contacted Quicken Support, they are the ones that should be escalating this problem?

    As for this:

    Express Web Connect - contract with your OFX/Online Banking Provider might be required.
    If the Bank does not have a contract does Quicken support QFX only?

    The very fact that it is listed in Quicken as a supported financial institution says that the contract is already there.  And here is the listing in the file that is used to determine that (which comes from Intuit).
    As for supporting Direct Connect that is up to the financial institution, Quicken can flip some switch and make it happen.  The financial institution has to agree to the contract, plus they have to run a OFX server on their server(s).  Direct Connect is Quicken talking directly to the OFX server at the financial institution.
    67376	67376	67376	First Progress Platinum MasterCd	https://www.firstprogress.com/	NA	https://cc.firstprogress.com/login	ACTIVE	 	 	 	CREDIT,ACCOUNTINFO&EXP-WEB-CONNECT	NOT_QBP	NA
    
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    P.S. it is the EXP-WEB-CONNECT that is stating that what is supported is Express Web Connect.  If they supported Direct Connect there would be DIRECT label used in that line.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • alannsandiego
    alannsandiego Member ✭✭
    Yes I contacted Quicken Support at least 3 times, they did not offer to escalate the issue.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Well, about the only thing I can suggest is "insisting" that the escalate it, and if they won't ask to talk to a manager.  I would have hoped that the moderators would have pushed that for you, but it seems that for whatever reason that isn't happening.

    You could also contact the financial institution and maybe get them to contact Intuit/Quicken Inc and work it out.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • alannsandiego
    alannsandiego Member ✭✭
    6.2.2021 Quicken Support says they will not escalate the issue because the data is come incorrectly from the bank, even though the data goes thru the Intuit cloud before it is download.
    INTU.ACCESSMETHOD>EXPRESS-WEBCONNECT
    <INTU.LOGINURL>https://fdatafeed-ccqd.platform.intuit.com/CustomerCentral/api
    <INTU.ACCESSURL>https://fdatafeed-ccqd.platform.intuit.com/CustomerCentral/api
    Quicken again refused to escalate this issue again today.
  • alannsandiego
    alannsandiego Member ✭✭
    such a simple issue to fix and no help in two weeks.
  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    such a simple issue to fix and no help in two weeks.

    BECAUSE IT'S YOUR BANK THAT NEEDS TO FIX THIS!
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • alannsandiego
    alannsandiego Member ✭✭
    The Bank does not know anything about Quicken
  • alannsandiego
    alannsandiego Member ✭✭
    First Progress MasterCard is not a bank and they do not know who there Online Banking Provider is,
    that is why only Quicken can fix this.
  • NotACPA
    NotACPA SuperUser, Windows Beta Beta


    <INTU.MASTERID>67376
    </INTU.BIDINFO>
    <INTU.BRANDDETAILS>
    <INTU.BRANDNAME>First Progress Platinum MasterCd
    <INTU.STATUS>ACTIVE
    <INTU.NPCFLAG>OFX
    <INTU.MKTTIERTYPE>BANKING
    <INTU.MKTTIERCD>1
    <INTU.MKTDISTMETHOD>Retail
    <FI>
    <ORG>Customer Central
    <FID>67376
    </FI>
    <ADDR1>N/A
    <CITY>N/A
    <STATE>N/A
    <POSTALCODE>N/A
    <COUNTRY>USA
    <CSPHONE>N/A
    <URL>https://www.firstprogress.com/
    <INTU.FIPROFILEURL>Web Connect Only
    <INTU.SVCLIST>
    <INTU.SVC>CCSVC
    <INTU.SVC>ACCTINFOSVC
    </INTU.SVCLIST>
    <INTU.SPURLLIST>
    <INTU.SPURL>https://www.dummyspurl.com
    </INTU.SPURLLIST>
    <INTU.ENROLLURL>https://cc.firstprogress.com/login
    <INTU.BROWSERCENTRIC>
    <INTU.WEBFEATURENM>CCSTMTRS
    <INTU.ACCESSMETHOD>EXPRESS-WEBCONNECT
    <INTU.LOGINURL>https://fdatafeed-ccqd.platform.intuit.com/CustomerCentral/api
    <INTU.ACCESSURL>https://fdatafeed-ccqd.platform.intuit.com/CustomerCentral/api

    The bank is sending the information but Quicken is loading the information info Quicken wrong.
    There is NOTHING in this unnecessarily lengthy post that shows the <TRNAMT> field.  So your claim that the bank is sending it properly is unsupported.
    Try saving a downloaded QFX file and extracting from that.  You could also try looking in the OFX Log.
    Here's an example of such a debit transaction "<TRNAMT>-600.00" actually sent by my bank.


    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • Quicken Sarah
    Quicken Sarah Administrator, Moderator mod
    edited June 2 Accepted Answer
    NotACPA said:
    There is NOTHING in this unnecessarily lengthy post that shows the <TRNAMT> field.  So your claim that the bank is sending it properly is unsupported.
    Try saving a downloaded QFX file and extracting from that.  You could also try looking in the OFX Log.
    Here's an example of such a debit transaction "<TRNAMT>-600.00" actually sent by my bank.


    Hello @NotACPA

    Thank you for your interest in this post.  I can confirm that we are investigating this issue and I have reviewed the log files and verified the financial institution is sending the amounts correctly and we are investigating further as a possible bug in Quicken.

    I'll be back to share any updates and/or the ticket number as they become available.

    Sarah
  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    @Quicken Sarah  Thanks for the clarification.
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
Sign In or Register to comment.