Investment register transaction sort order

dnort
dnort Member
I have an issue with how Quicken is re-ordering items in the investment account registers lately. I’m not sure what recent update brought this undesirable feature in. I'm running version R40.21 now. My last update installed R40.13 and R40.21 at the same time so I'm not sure which one caused this mess.

It used to be items entered on the same day were sorted in the order that you entered them in. Not anymore. For example, I have a series of Sold entries that should be followed by a MiscExp entry. But now the MiscExp is at the top, followed by all the Sold entries. The way this sorts now my cash balance shows a bunch of negative values starting at the MiscExp line and continues until the last Sold is done.

The same holds true for my 401k entries. All the Buy entries are moved before the Xin entry. This also results in a series of negative cash balances.

I can't think of any reason for the out entries to be moved ahead of the in entries.

Best Answer

  • Quicken Anja
    Quicken Anja Moderator mod
    Answer ✓
    Hello All,

    Thank you for taking the time to the Community with feedback about this investment register change.

    Our teams are aware of this and are working on an option to customize this in a future release, though we do not have an ETA at this time.

    We apologize for any inconvenience in the meantime! Thank you.
    -Quicken Anja

Answers

  • dnort
    dnort Member
    The register also use to sort the buys the same as you entered them. Now is looks like it is alphabetizing them, which is not what I like or want.
  • Marc Dupont
    Marc Dupont Member ✭✭
    I have observed the same thing after having installed release 40.23 and notice that this new behavior is listed as a new feature in the release notice (see attached clip).

    This change is not compatible with my workflow. I manually enter several transactions when I receive my monthly statement, and some dates have several transactions. It's quite strange to see the transaction you have just entered shoot up in the register and to have to scroll for it to make sure you input the numbers correctly. It also makes it more difficult to compare the register to the monthly statement.

    At least provide a switch to turn off this secondary sort key.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    See this thread.  For some reason Quicken Inc thought this was a good idea, but it isn’t.
    Note that with the latest Canadian release you are now in the same boat.
    https://community.quicken.com/discussion/7912102/r40-13-reintroduces-investment-transaction-sort-order-bug
    Signature:
    This is my website: http://www.quicknperlwiz.com/
  • ML Johnston
    ML Johnston Member ✭✭
    I say ditto to the previous comments. This change seems to have no useful purpose. We need to return to a conventional transaction order to be compatible with everyone else. Isn't this just common sense?
    Does anyone know how we can get their attention to either return to normal or at least give us an option?
  • owh
    owh Member
    This alphabetical order transaction display is NUTS!!! Very confusing. Please change it BACK!
  • Quicken Anja
    Quicken Anja Moderator mod
    Answer ✓
    Hello All,

    Thank you for taking the time to the Community with feedback about this investment register change.

    Our teams are aware of this and are working on an option to customize this in a future release, though we do not have an ETA at this time.

    We apologize for any inconvenience in the meantime! Thank you.
    -Quicken Anja
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    It would certainly be interesting to hear the rationale for this change.

    To me, sorting the Transaction List with all the Buys before the Divs for a given date, followed by CGLong, then CGShort, Sell and Withdraw because that is the alphabetical order of the Actions and without regard to the order they were accepted makes no sense whatsoever.
    QWin Premier subscription
  • schau
    schau Member ✭✭
    Same here. I just noticed this. This is totally undesirable! When you do end up fixing it, will it remember the order the transactions were entered? Right now, 30 years of investment transactions are messed up for me!
  • Kent P
    Kent P Member
    I agree, ever since I have used Quicken, transactions entered in date order stayed in that order. Now they by sorted by type of transaction for all of transactions entered for that date. I cannot believe there is not an option to keep investment transactions in date\time entered order. Sorting by transaction type within a set date is not helpful.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    schau said:
    Same here. I just noticed this. This is totally undesirable! When you do end up fixing it, will it remember the order the transactions were entered? Right now, 30 years of investment transactions are messed up for me!
    Your data isn't changed, just the way it is sorted.  Once they fix it, the data show fine.
    Signature:
    This is my website: http://www.quicknperlwiz.com/
  • schau
    schau Member ✭✭
    > @Chris_QPW said:
    > Your data isn't changed, just the way it is sorted.  Once they fix it, the data show fine.

    I understand. As long as the metadata still includes the info of time entered, it will be fine. I was just wondering if that info would be lost.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    schau said:
    > @Chris_QPW said:
    > Your data isn't changed, just the way it is sorted.  Once they fix it, the data show fine.

    I understand. As long as the metadata still includes the info of time entered, it will be fine. I was just wondering if that info would be lost.
    Just as a follow up as why I'm sure that the data is fine.  They first introduced this "feature" quite a few versions back.  People complained, and they backed out the changes, and everything went back to the way it was.  For some reason, they put the changes back in with the same result.  They have said that they are now looking into making it optional, so I fully except it to be the same way.
    Signature:
    This is my website: http://www.quicknperlwiz.com/
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    R41.9 (Quicken Windows US) is in stagged release mode (and paused at the moment/as in released to a limited number of users), and it fixes this problem.  There is now a preference to decide how to do the sort, and it defaults to off, which is to say, the old way of sorting is the default.



    And as expected, all my transactions are back in the order expected after updating to this release.
    Signature:
    This is my website: http://www.quicknperlwiz.com/
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    @Chris_QPW
    Thanks for the notice. Any confirmation that sort by security really does that rathe than actually sorting by Action as the last release did?
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    q_lurker said:
    @Chris_QPW
    Thanks for the notice. Any confirmation that sort by security really does that rathe than actually sorting by Action as the last release did?
    The name of the preference would probably be better stated as sort by action and then by security.
    The "not selected", is sort by how transactions were entered.

    With the preference on:

    With it off:

    Signature:
    This is my website: http://www.quicknperlwiz.com/
  • schau
    schau Member ✭✭
    Looks like it has been fixed in the latest update! Thank you Quicken!
  • schau
    schau Member ✭✭
    > @Chris_QPW said:
    > Just as a follow up as why I'm sure that the data is fine.  They first introduced this "feature" quite a few versions back.  People complained, and they backed out the changes, and everything went back to the way it was.  For some reason, they put the changes back in with the same result.  They have said that they are now looking into making it optional, so I fully except it to be the same way.

    Thanks! Looks like it has been fixed!
  • dnort
    dnort Member
    Glad to see this has become optional in R41.9 and that it defaults to off.
This discussion has been closed.