Citibank Reauthorization failure- Webpage "Citibank Consent" is blank



  • GeezerGeek
    GeezerGeek Member ✭✭✭

    Me too. I have gotten the blank screen for the past 3 days and have been unable to reauthorize. However, when I changed the default browser to Edge, I was able to reauthorize.

    Quicken user since 1991, DOS version
  • Vegasguy
    Vegasguy Member

    Had the same problem using Safari, Chrome and Duck Duck Go. Just a blank screen. Then I went into Safari Privacy settings and unchecked Prevent cross-site tracking and Hide IP address and Citi authorization worked like a charm.

  • DetroitRick
    DetroitRick Member ✭✭✭

    Same problem, but is now working. To fix this, I shut off both my privacy tools (in my case Ghostery and Ad Block Plus). I was then immediately able to reauthorize and that page was no longer blank. My browser is Chrome.

  • Creek
    Creek Member ✭✭

    Yep — I'm also in the Reauthorization Cycle of Death. Seems they botched this one…

  • davezechnich
    davezechnich Member ✭✭

    The reauthorize Citibank failed several times in both Chrome and Edge, but I succeeded quickly using Firefox.

  • Mmdwyer2006
    Mmdwyer2006 Member ✭✭

    Looks like they may have fixed it. Had same problem. Didn't work but kept trying with NO CHANGES to the browser, keyboard shortcuts, etc. Last night I decided to try with the shift-refresh hack. Tried one last time without any changes and it worked fine. Dumping my bookmark on this thread since I am tired of the hundred emails.

  • CowgirlnSand

    just ignore it by selecting 'remind me next time' and just update all accounts, Citi will be there and will be updated…

  • Lisa Conrad
    Lisa Conrad Member ✭✭

    It's working! They must have fixed it on their end because after trying multiple things over the past few days, it magically worked today trying it the original settings (default browser is Chrome). Try it again!

  • timbo28
    timbo28 Member ✭✭

    Just toggled Firefox to be my default browser, ran the update successfully, and then toggled back to Chrome as my default. It's not pretty but it worked.

  • PBK77
    PBK77 Member ✭✭

    Changed default browser from Edge to Chrome and it appeared to work. Hopefully, it will CONTINUE to work…

  • John24
    John24 Member ✭✭

    Mine was failing with a blank screen and I was using the Brave Browser. I changed my default Browser to Chrome, and it worked perfectly. Looks like Quicken is only testing their stuff on the top browsers. Even though Brave is a Chromium Based Browser, it did not work.

  • mschloss
    mschloss Member

    Shift+Refresh worked for me with Chrome. I was then able to login and (re)connect two existing accounts without issue.

    Let the good times roll…

  • Steve212@
    Steve212@ Member ✭✭

    I spoke with Citi Tech Support. They said that they are having a problem with Chrome Browsers, and they hoped to have it resolved by Jan 29, 2024.

    They suggested that I download transactions from each of the credit cards separately, and import the transactions into Quicken.

    I have tried to use the bank-hosted sign-in form from a Bing browser. I can connect to Citi, but it still does not connect to Quicken.

    Maybe the right hand can talk to the left hand, and find a solution that works for all.


  • Lavatan
    Lavatan Member ✭✭

    I just cleared my browser cache for all time and tried it again. Works.

  • Jack92708
    Jack92708 Member

    Same problem!

  • 932Scooter419
    932Scooter419 Member ✭✭

    Repeated attempts to reauthorize with Edge as default are not working. I even logged in to Citi on another Edge tab and it still failed. Basically Quicken passes some URL to (default browser) Edge, seemingly blank page loads, and nothing happens. I've had to cancel in Quicken at least half-a-dozen times.

  • rky392491
    rky392491 Member ✭✭

    Using Quicken Classic Premier for Windows (R54.9, Build, I'm trying to set up One Step Update for an existing credit card (it was setup previously and stopped downloading any transactions about two months ago). I believe it was previously using Direct Connect and needs to be updated to Express Web Connect Plus.

    I get to the Activate One Step Update dialog in Quicken which says Citi Cards needs you to authorize your accounts. I click Sign In and a browser window opens prompting me to sign into the account. I sign into the account and authorize Quicken to access the account. I get a message in the browser stating that the accounts have been authorized successfully and that I will be redirected back to Quicken (and if not, I can close the window and return to Quicken). I don't get redirected and closing the window makes no difference with what happens in Quicken.

    Back in Quicken, the dialog continues to wait (displaying a spinner) and eventually times out with a message stating "Sign iinto Citi Cards bank failed. Try again. Sorry, the sign in failed due to time out or a connection error. Select Sign in to authenticate via your web browser".

    It appears that the successful authorization is never making it back to the Quicken app. At one time, my Bitdefender online threat prevention warned of an issue with, but I added an exception for that and have retried numerous times since. I have also tried disabling Windows Firewall and that did not make any difference either.

  • rky392491
    rky392491 Member ✭✭

    Additional information: I do have Chase and Amex credit card accounts that were switched to Express Web Connect Plus. I just ran a reset on the online connection for Amex and it successfully returned to Quicken to the screen to link the found accounts to Quicken accounts, so the issue may be specific to Citi Bank.

  • rrdozier
    rrdozier Member ✭✭✭

    I just switched my Mac version to Direct connect and it seems to be holding the login info. Have not tried it on my wife’s Windows version yet.

  • rrdozier
    rrdozier Member ✭✭✭

    I just tried to do this Direct Connect on my wife's Windows version and I do not get the option to pick Direct Connect

  • pfrose2101
    pfrose2101 Member ✭✭✭

    I am now in the same situation, except when I switch my default browser from Firefox to Edge I get the blank authorization screen. That is, Firefox seems to allow me to authorize with Citi, but Edge does not.

  • KM7516
    KM7516 Member

    Based on what others did I followed their steps. What cleared the issue with Citibank reauthentication follows (mileage may differ):

    1. In your default browser clear your cache

    2. Clear the setup for Citibank in the Citibank setup.

    3. Reboot your system - just clearing the cache didn't work

    4. After reboot start up Quicken. If you auto update at start don't let do it this time.

    5. Go into the Citibank setup and setup

    6. It took 30 seconds or more to get past a white (blank) window. Quicken message.

    7. Select continue

    8. It took 30 seconds or more to get to a new panel asking to login into Citibank

    9. Once you logon your accounts will be presented

    10. Select the accounts and quicken will display how you want to link them. It seemed slower than prior methods though everything worked.

    I used MSFT Edge on Windows 11 Professional. Your mileage may differ.

  • keganje
    keganje Member ✭✭

    Clearing the Cache worked for me too! That is all I needed to do. ctrl+Shift+delete in Chrome

  • brownbutterfly31
    brownbutterfly31 Member
    edited January 26

    Hello. I am getting frustrated that Quicken can't seem to fix the Citibank connection. I was getting prompts to re-authoirze transaction downloads. When I clicked on re-authorize using edge window - all that populated was a blank window. When I used chrome, Citibank authorized the downloads, but Quicken doesn't seem to recognize that and says that the connection failed. So I am on day 5 of no downloads. Questions:

    1. how long does it take for Quicken to fix stuff like this?
    2. has anyone figured out how to fix this?
    3. Is there a work around i can use that won't cause me headaches in the long run like duplicate entries once Quicken does figure this out?

    I am using a PC - Microsoft. Have been a Quicken user before. Usually dump the product after a few months because of glitches like this and i'm kicking myself for coming back. Someone help.

    [Merged Post]

  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭✭

    There are several different things mentioned in this thread by various users of what they did to get the reauthorizations to work. So far there is not one solution that seems to work for everyone but there are 3-4 different solutions that have been proven to work for multiple people.

    Why don't you scroll through this thread and try doing the suggested workarounds? Let us know what your results are.

    Quicken Classic Premier (US) Subscription: R55.26 on Windows 11

  • danieleoh
    danieleoh Member ✭✭

    I have been following this thread few days and it seems issue is related to "Cached" content.

    In most of case, clearing cached content by opening new browser or clearing cache seems to work

    I have summarized issues and solutions, workaround here.


    1. Citibank Reautorize action will open webpage with blank page.
      User can't proceed to sign-in webpage as there is no login page..
    2. if success, Quicken download duplicate entires to all active account.

    Solutions provided from various users in this thread:

    1. Switch Default Webbroswer to other brower, specially to Firefox or Chrome

    2. Clean Caches, browser histories & cookies from webbrower, close all tabs, and restart Web browser for new session

    3. Change Firefox Brower Privacy from STRICT to STANDARD

    4. I got the reauthorization to work by changing my default browser to Chrome and then using the "add new account" plus mark above the account list in Quicken. This will take you to the Citi Cards login where you can authorize the accounts in question. Then Quicken will allow you to select "link to existing accounts"

    5. Using Chrome, select Clear Browsing Data, use the Sign out of Google account link at bottom to sign out so you don't lose history on all synced devices, select Clear History, Cache, and Images (I chose Last 4 Weeks). The run re-authorization. Was able to successfully load the Citi sign-on page, authorize my account, and have Quicken link to correct existing account. It said it was downloading transactions from last 928 days but no old transactions downloaded. YMMV.

    6. Refresh Browser with Shift + Browser Refresh
    I had the same issue (Windows/Firefox) and was able to solve the issue doing the following.
    1 - Allow browser to open via Quicken
    2 - Hold down shift key and then click on the browser reload icon
    3 - That seemed to allow the connection to continue with login
    4 - NOTE: The account chosen as existing was NOT correct. Ensure that you select the correct existing account before allowing update.

    Workaround -

    To use Remind me next time, not reauthorization

    in Quicken, I clicked Cancel and I got a "Do you want to continue?" "No" just goes back to the first screen (an endless loop). "Yes" closes the update. If you again try to run OneStep update, you get the reauthorize screen but in the lower-right corner you can click "Remind me next time." to continue with the original OneStep update.,

  • UTMike
    UTMike Member

    What fixed it for me (good luck)…

    Turn off the pop-up blocker in Edge.

    Choose "Coscto Anywhere Visa Card by City and try the reauthorization.

    If you get the clear screen, try hitting Shift Key and clicking the reset/reload icon at the top of the web page.

    Try it a couple of times (I did), and it might work (some say not).

    Important…if you're using the Costco card, pick Costco Anywhere Vicas Card by Citi - I picked "Citi" at first and Quicken would not consider it a credit card account, wouldn't let me link it to my card. Turn your pop-up blocker back on. Hope this helps.

  • SDJT
    SDJT Member

    same issue. thought it was a firewall issue but saw a comment to clear the browser cache and that worked!

  • dp_go_blue
    dp_go_blue Member ✭✭

    I was using chrome and was able to solve this problem my completely cleaning out the cookies and cache of chrome. Be sure to deactivate the online setup within this account first in quicken. After you remove the cookies and clean out the cache the setup a new account for Citibank and it will find your account so you can link it again.

  • Jackzip
    Jackzip Member

    I also cleared the Chrome cookies and cache and it worked! Thanks for finding the solution.

This discussion has been closed.